NDP(8) BSD System Manager's Manual NDP(8)
ndp -- control/diagnose IPv6 neighbor discovery protocol
ndp [-nt] hostname
ndp [-nt] -a | -c | -p
ndp [-nt] -r
ndp [-nt] -H | -P | -R
ndp [-nt] -A wait
ndp [-nt] -d hostname
ndp [-nt] -f filename
ndp [-nt] -i interface [flags ...]
ndp [-nt] -I [interface | delete]
ndp [-nt] -s nodename etheraddr [temp] [proxy]
The ndp utility manipulates the address mapping table used by the Neigh-
bor Discovery Protocol (NDP).
-a Dump the currently existing NDP entries. The following informa-
tion will be printed:
Neighbor IPv6 address of the neighbor.
Linklayer address of the neighbor. It could be
``(incomplete)'' when the address is not available.
Netif Network interface associated with the neighbor cache
Expire The time until expiry of the entry. The entry could
become ``permanent'', in which case it will never
S State of the neighbor cache entry, as a single let-
? Unknown state (should never happen).
Flags Flags on the neighbor cache entry, in a single let-
ter. They are: Router, proxy neighbor advertisement
(``p''). The field could be followed by a decimal
number, which means the number of NS probes the node
has sent during the current state.
Repeat -a (dump NDP entries) every wait seconds.
-c Erase all the NDP entries.
-d Delete specified NDP entry.
-f Parse the file specified by filename.
-H Harmonize consistency between the routing table and the default
router list; install the top entry of the list into the kernel
-I Shows the default interface used as the default route when there
is no default router.
Specifies the default interface used as the default route when
there is no default router. The interface will be used as the
The current default interface will be deleted from the kernel.
-i interface [flags ...]
View ND information for the specified interface. If additional
arguments flags are given, ndp sets or clears the specified flags
for the interface. Each flag should be separated by white spaces
or tab characters. Possible flags are as follows. All of the
flags can begin with the special character '-', which means the
flag should be cleared. Note that you need -- before -foo in
nud Turn on or off NUD (Neighbor Unreachability Detection) on
the interface. NUD is usually turned on by default.
Specify whether or not to accept Router Advertisement
messages received on the interface. Note that the kernel
does not accept Router Advertisement messages unless the
net.inet6.ip6.accept_rtadv variable is non-0, even if the
flag is on. This flag is set to 1 by default.
Prefer addresses on the interface as candidates of the
source address for outgoing packets. The default value
of this flag is off. For more details about the entire
algorithm of source address selection, see the
IMPLEMENTATION file supplied with the KAME kit.
-n Do not try to resolve numeric addresses to hostnames.
-p Show prefix list.
-P Flush all the entries in the prefix list.
-r Show default router list.
-R Flush all the entries in the default router list.
-s Register an NDP entry for a node. The entry will be permanent
unless the word temp is given in the command. If the word proxy
is given, this system will act as a proxy NDP server, responding
to requests for hostname even though the host address is not its
-t Print timestamp on each entry, making it possible to merge output
with tcpdump(8). Most useful when used with -A.
The ndp utility exits 0 on success, and >0 if an error occurs.
The ndp utility first appeared in the WIDE Hydrangea IPv6 protocol stack
BSD May 17, 1998 BSD