NDP(8) BSD System Manager's Manual NDP(8)
ndp -- control/diagnose IPv6 neighbor discovery protocol
ndp -a [-nt]
ndp -A wait [-nt]
ndp -c [-nt]
ndp -d [-nt] hostname
ndp -f [-nt] filename
ndp -I [delete | interface]
ndp -i interface [flags...]
ndp -s [-nt] nodename ether_addr [temp] [proxy]
The ndp command manipulates the address mapping table used by Neighbor
Discovery Protocol (NDP).
-a Dump the currently existing NDP entries.
Repeat -a (dump NDP entries) every wait seconds.
-c Erase all the NDP entries.
-d Delete specified NDP entry.
-f Parse the file specified by filename.
-H Harmonize consistency between the routing table and the default
router list; install the top entry of the list into the kernel
-I [delete | interface]
Shows or specifies the default interface used as the default
route when there is no default router. If no argument is given
to the option, the current default interface will be shown. If
an interface is specified, the interface will be used as the
default. If a special keyword delete is specified, the current
default interface will be deleted from the kernel.
-i interface [flags...]
View ND information for the specified interface. If additional
arguments flags are given, ndp sets or clears the specified flags
for the interface. Possible flags are as follows. All of the
flags can begin with the special character '-', which means the
flag should be cleared.
nud turn on or off NUD (Neighbor Unreachability Detection) on
the interface. NUD is usually turned on by default.
-n Do not try to resolve numeric address to hostname.
-p Show prefix list.
-P Flush all the entries in the prefix list.
-r Show default router list.
-R Flush all the entries in the default router list.
-s Register an NDP entry for a node. The entry will be permanent
unless the word temp is given in the command. If the word proxy
is given, this system will act as an proxy NDP server, responding
to requests for hostname even though the host address is not its
-t Print timestamp on each entries, to make it possible to merge
output with tcpdump(1). Most useful when used with -A.
The ndp command will exit with 0 on success, and non-zero on errors.
The ndp command first appeared in WIDE Hydrangea IPv6 protocol stack kit.
BSD May 17, 1998 BSD