MOUNT_UMAP(8) OpenBSD System Manager's Manual MOUNT_UMAP(8)
mount_umap - sample file system layer
mount_umap [-o options] -u uid-mapfile -g gid-mapfile target mount_point
The mount_umap command is used to mount a subtree of an existing file
system that uses a different set of UIDs and GIDs than the local system.
Such a file system could be mounted from a remote site via NFS or it
could be a file system on removable media brought from some foreign loca-
tion that uses a different password file.
The options are as follows:
Options are specified with a -o flag followed by a comma separat-
ed string of options. See the mount(8) man page for possible op-
tions and their meanings.
Use the group ID mapping specified in gid-mapfile. This flag is
Use the user ID mapping specified in uid-mapfile. This flag is
The mount_umap command uses a set of files provided by the user to make
correspondences between UIDs and GIDs in the subtree's original environ-
ment and some other set of IDs in the local environment. For instance,
user smith might have UID 1000 in the original environment, while having
UID 2000 in the local environment. The mount_umap command allows the
subtree from smith's original environment to be mapped in such a way that
all files with owner UID 1000 look like they are actually owned by UID
target should be the current location of the subtree in the local sys-
tem's name space. mount_point should be a directory where the mapped
subtree is to be placed. uid-mapfile and gid-mapfile describe the map-
pings to be made between identifiers.
The format of these files is very simple. The first line is a count of
the number of mappings. Each subsequent line contains two numbers. The
first is the ID in the mapped subtree, and the second is the ID in the
original subtree. IDs in the original subtree for which no mapping ex-
ists will be mapped to ``nobody''. At most 64 UIDs can be mapped for a
given subtree, and at most 16 groups can be mapped by a given subtree.
The mapfiles can be located anywhere in the file hierarchy, but they must
be owned by root, and they must be writable only by root. mount_umap
will refuse to map the subtree if the ownership or permissions on these
files are improper. It will also balk if the count of mappings in the
first line of the map files is not correct.
mount(2), mount(8), mount_null(8)
The mount_umap utility first appeared in 4.4BSD.
It is not meant for production use. The implementation is not very so-
OpenBSD 3.6 March 27, 1994 1