MOUNT_PROCFS(8) BSD System Manager's Manual MOUNT_PROCFS(8)
mount_procfs - mount the process file system
mount_procfs [-o options] /proc mount_point
The mount_procfs command attaches an instance of the process namespace to
the global filesystem namespace. The conventional mount point is /proc.
This command is normally executed by mount(8) at boot time.
The options are as follows:
-o Options are specified with a -o flag followed by a comma separat-
ed string of options. See the mount(8) man page for possible op-
tions and their meanings.
The root of the process filesystem contains an entry for each active pro-
cess. These processes are visible as a directory whose name is the pro-
cess' pid. In addition, the special entry curproc references the current
Each directory contains several files.
ctl a writeonly file which supports a variety of control operations.
Control commands are written as strings to the ctl file. The
control commands are:
attach stops the target process and arranges for the sending
process to become the debug control process.
detach continue execution of the target process and remove it
from control by the debug process (which need not be the
run continue running the target process until a signal is de-
livered, a breakpoint is hit, or the target process ex-
step single step the target process, with no signal delivery.
wait wait for the target process to come to a steady state
ready for debugging. The target process must be in this
state before any of the other commands are allowed.
The string can also be the name of a signal, lower case and with-
out the SIG prefix, in which case that signal is delivered to the
process (see sigaction(2)).
file A reference to the vnode from which the process text was read.
This can be used to gain access to the process' symbol table, or
to start another copy of the process.
mem The complete virtual memory image of the process. Only those ad-
dress which exist in the process can be accessed. Reads and
writes to this file modify the process. Writes to the text seg-
ment remain private to the process.
note Not implemented.
notepg Not implemented.
regs Allows read and write access to the process' register set. This
file contains a binary data structure struct regs defined in
<machine/reg.h>. regs can only be written when the process is
fpregs The floating point registers as defined by struct fpregs in
<machine/reg.h>. fpregs is only implemented on machines which
have distinct general purpose and floating point register sets.
status The process status. This file is readonly and returns a single
line containing multiple space-separated fields as follows:
o command name
o process id
o parent process id
o process group id
o session id
o major,minor of the controlling terminal, or -1,-1 if there is
no controlling terminal.
o a list of process flags: ctty if there is a controlling ter-
minal, sldr if the process is a session leader, noflags if
neither of the other two flags are set.
o the process start time in seconds and microseconds, comma
o the user time in seconds and microseconds, comma separated.
o the system time in seconds and microseconds, comma separated.
o the wait channel message
o the process credentials consisting of the effective user id
and the list of groups (whose first member is the effective
group id) all comma separated.
In a normal debugging environment, where the target is fork/exec'd by the
debugger, the debugger should fork and the child should stop itself (with
a self-inflicted SIGSTOP for example). The parent should issue a wait
and then an attach command via the appropriate ctl file. The child pro-
cess will receive a SIGTRAP immediately after the call to exec (see
sigaction(2), mount(2), unmount(2),
No . and .. entries appear when listing the contents of the /proc direc-
tory. This makes sense in the context of this filesystem, but is incon-
sistent with usual filesystem conventions. However, it is still possible
to refer to both . and .. in a pathname.
This filesystem may not be NFS-exported since most of the functionality
of procfs requires that state be maintained.
The mount_procfs utility first appeared in 4.4BSD.
4.4BSD June 1, 1994 2