MOUNT_PORTAL(8) BSD System Manager's Manual MOUNT_PORTAL(8)
mount_portal - mount the portal daemon
mount_portal [-o options] /etc/portal.conf mount_point
The mount_portal command attaches an instance of the portal daemon to the
global filesystem namespace. The conventional mount point is /p. This
command is normally executed by mount(8) at boot time.
The options are as follows:
-o Options are specified with a -o flag followed by a comma separat-
ed string of options. See the mount(8) man page for possible op-
tions and their meanings.
The portal daemon provides an open service. Objects opened under the
portal mount point are dynamically created by the portal daemon according
to rules specified in the named configuration file. Using this mechanism
allows descriptors such as sockets to be made available in the filesystem
The portal daemon works by being passed the full pathname of the object
being opened. The daemon creates an appropriate descriptor according to
the rules in the configuration file, and then passes the descriptor back
to the calling process as the result of the open system call.
By convention, the portal daemon divides the namespace into sub-
namespaces, each of which handles objects of a particular type.
Currently, two sub-namespaces are implemented: tcp and fs. The tcp names-
pace takes a hostname and a port (slash separated) and creates an open
TCP/IP connection. The fs namespace opens the named file, starting back
at the root directory. This can be used to provide a controlled escape
path from a chrooted environment.
The configuration file contains a list of rules. Each rule takes one
line and consists of two or more whitespace separated fields. A hash
(``#'') character causes the remainder of a line to be ignored. Blank
lines are ignored.
The first field is a pathname prefix to match against the requested path-
name. If a match is found, the second field tells the daemon what type
of object to create. Subsequent fields are passed to the creation func-
# @(#)portal.conf 5.1 (Berkeley) 7/13/92
tcp/ tcp tcp/
fs/ file fs/
mount(2), unmount(2), fstab(5), mount(8)
This filesystem may not be NFS-exported.
The mount_portal utility first appeared in 4.4BSD.