MOUNT_NFS4(8) BSD System Manager's Manual MOUNT_NFS4(8)
mount_nfs4 -- mount NFSv4 file systems
mount_nfs4 [-NPTUbcdiLls] [-D deadthresh] [-I readdirsize] [-R retrycnt]
[-a maxreadahead] [-g maxgroups] [-o options] [-r readsize]
[-t timeout] [-w writesize] [-x retrans] rhost:path node
The mount_nfs4 utility calls the mount(2) system call to prepare and
graft a remote NFSv4 file system (rhost:path) on to the file system tree
at the point node. This command is normally executed by mount(8). It
implements the NFSv4 protocol as described in RFC 3530, NFS version 4
If the server becomes unresponsive while an NFSv4 file system is mounted,
any new or outstanding file operations on that file system will hang
uninterruptibly until the server comes back. To modify this default be-
haviour, see the -i and -s flags.
The options are:
-D Set the ``dead server threshold'' to the specified number of
round trip timeout intervals before a ``server not responding''
message is displayed.
-I Set the readdir read size to the specified value. The value
should normally be a multiple of DIRBLKSIZ that is <= the read
size for the mount.
-N Do not use a reserved socket port number (see below).
-P Use a reserved socket port number. This flag is obsolete, and
only retained for compatibility reasons. Reserved port numbers
are used by default now. (For the rare case where the client has
a trusted root account but untrustworthy users and the network
cables are in secure areas this does help, but for normal desktop
clients this does not apply.)
-R Set the mount retry count to the specified value. The default is
a retry count of zero, which means to keep retrying forever.
There is a 60 second delay between each attempt.
-T Use TCP transport. This is the default.
-U Force the mount protocol to use UDP transport. This is not sup-
ported by the version 4 protocol and is provided only for debug-
-a Set the read-ahead count to the specified value. This may be in
the range of 0 - 4, and determines how many blocks will be read
ahead when a large file is being read sequentially. Trying a
value greater than 1 for this is suggested for mounts with a
large bandwidth * delay product.
-b If an initial attempt to contact the server fails, fork off a
child to keep trying the mount in the background. Useful for
fstab(5), where the file system mount is not critical to multi-
-i Make the mount interruptible, which implies that file system
calls that are delayed due to an unresponsive server will fail
with EINTR when a termination signal is posted for the process.
-o Options are specified with a -o flag followed by a comma sepa-
rated string of options. See the mount(8) man page for possible
options and their meanings. The following NFS specific options
are also available:
Use specified port number for NFSv4 requests. The
default is to use port 2049. Set this to 0 to query the
portmapper for the NFSv4 port.
When attributes of files are cached, a timeout calculated
to determine whether a given cache entry has expired.
These four values determine the upper and lower bounds of
the timeouts for ``directory'' attributes and ``regular''
(i.e., everything else). The default values are 3 -> 60
seconds for regular files, and 30 -> 60 seconds for
directories. The algorithm to calculate the timeout is
based on the age of the file. The older the file, the
longer the cache is considered valid, subject to the lim-
Disables AF_INET or AF_INET6 connections. Useful for
hosts that have both an A record and an AAAA record for
the same name.
-s A soft mount, which implies that file system calls will fail
after retrycnt round trip timeout intervals.
-t Set the initial retransmit timeout to the specified value. May
be useful for fine tuning UDP mounts over internetworks with high
packet loss rates or an overloaded server. Try increasing the
interval if nfsstat(1) shows high retransmit rates while the file
system is active or reducing the value if there is a low retrans-
mit rate but long response delay observed. (Normally, the -d
option should be specified when using this option to manually
tune the timeout interval.)
-x Set the retransmit timeout count for soft mounts to the specified
mount(2), unmount(2), fstab(5), idmapd(8), mount(8), mount_nfs(8),
This version of the NFSv4 client, while functional, is a long way from
compliance with RFC 3530. It lacks lock state, reboot recovery, delega-
tion, GSS, and many other mandatory items from the RFC.
BSD November 14, 2003 BSD