MOUNT_NFS(8) OpenBSD System Manager's Manual MOUNT_NFS(8)
mount_nfs - mount NFS file systems
mount_nfs [-23PTUbcdilqs] [-D deadthresh] [-I readdirsize] [-L leaseterm]
[-R retrycnt] [-a maxreadahead] [-g maxgroups] [-o options]
[-r readsize] [-t timeout] [-w writesize] [-x retrans]
The mount_nfs command calls the mount(2) system call to prepare and graft
a remote NFS file system (rhost:path) on to the file system tree at the
point node. This command is normally executed by mount(8). It imple-
ments the mount protocol as described in RFC 1094, Appendix A and NFS:
Network File System Version 3 Protocol Specification, Appendix I.
The options are as follows:
-2 Use the NFS Version 2 protocol.
-3 Use the NFS Version 3 protocol. The default is to try version 3
first, and fall back to version 2 if the mount fails.
Set the readdir read size to the specified value. The value
should normally be a multiple of DIRBLKSIZ that is <= the read
size for the mount.
-P The kernel always uses a reserved port number to communicate with
clients. This option is ignored, and exists solely for compati-
bility with older systems.
Set the retry count for doing the mount to the specified value.
The default is 10000.
-T Use TCP transport instead of UDP. This is recommended for
servers that are not on the same LAN cable as the client. (NB:
This is NOT supported by most non-BSD servers.)
-U Force the mount protocol to use UDP transport, even for TCP NFS
mounts. (Necessary for some old BSD servers.)
Set the read-ahead count to the specified value. This may be in
the range of 0 - 4, and determines how many blocks will be read
ahead when a large file is being read sequentially. Trying a
value greater than 1 for this is suggested for mounts with a
large bandwidth * delay product.
-b If an initial attempt to contact the server fails, fork off a
child to keep trying the mount in the background. Useful for
fstab(5), where the filesystem mount is not critical to multiuser
-c For UDP mount points, do not do a connect(2). This must be used
for servers that do not reply to requests from the standard NFS
port number 2049. It may also be required for servers with more
than one IP address (only necessary if replies come from an ad-
dress other than the one specified in the mount request).
-d Turn off the dynamic retransmit timeout estimator. This may be
useful for UDP mounts that exhibit high retry rates, since it is
possible that the dynamically estimated timeout interval is too
Set the maximum size of the group list for the credentials to the
specified value. This should be used for mounts on old servers
that cannot handle a group list size of 16, as specified in RFC
1057. Try 8, if users in a lot of groups cannot get a response
from the mount point.
-i Make the mount interruptible, which implies that file system
calls that are delayed due to an unresponsive server will fail
with EINTR when a termination signal is posted for the process.
-l Used with NFSV3 to specify that the ReaddirPlus RPC should be
used. This option reduces RPC traffic for cases such as ``ls
-l'', but tends to flood the attribute and name caches with
prefetched entries. Try this option and see whether performance
improves or degrades. Probably most useful for client to server
network interconnects with a large bandwidth times delay product.
Options are specified with a -o flag followed by a comma separat-
ed string of options. See the mount(8) man page for possible op-
tions and their meanings. The following NFS specific options are
Cache file attributes for no more than num seconds. The
default is 60 seconds.
Cache file attributes for at least num seconds. The de-
fault is 5 seconds.
Cache directory attributes for no more than num seconds.
The default is 60 seconds.
Cache directory attributes for at least num seconds. The
default is 5 seconds.
noac Disable attribute caching for both files and directories.
Use specified port number for NFS requests. The default
is to query the portmapper for the NFS port.
Set the read data size to the specified value. It should normal-
ly be a power of 2 greater than or equal to 1024. This should be
used for UDP mounts when the ``fragments dropped due to timeout''
value is getting large while actively using a mount point. (Use
netstat(1) with the -s option to see what the ``fragments dropped
due to timeout'' value is.) See the -w option as well.
-s A soft mount, which implies that file system calls will fail af-
ter Retry round trip timeout intervals.
Set the initial retransmit timeout to the specified value. May
be useful for fine tuning UDP mounts over internetworks with high
packet loss rates or an overloaded server. Try increasing the
interval if nfsstat(1) shows high retransmit rates while the file
system is active or reducing the value if there is a low retrans-
mit rate but long response delay observed. (Normally, the -d op-
tion should be specified when using this option to manually tune
the timeout interval.)
Set the write data size to the specified value. Ditto the com-
ments w.r.t. the -r option, but using the ``fragments dropped due
to timeout'' value on the server instead of the client. Note
that both the -r and -w options should only be used as a last
ditch effort at improving performance when mounting servers that
do not support TCP mounts.
Set the retransmit timeout count for soft mounts to the specified
In versions prior to OpenBSD 2.7, nfsiod daemons were running to improve
performance of client NFS I/O. This is no longer done this way. Use
sysctl(8) or modify sysctl.conf(5) to adjust the vfs.nfs.iothreads value,
which is the number of kernel threads created to serve asynchronous NFS
mount(2), fstab(5), mount(8), nfsd(8), sysctl(8), umount(8)
Due to the way that Sun RPC is implemented on top of UDP (unreliable
datagram) transport, tuning such mounts is really a black art that can
only be expected to have limited success. For clients mounting servers
that are not on the same LAN cable or that tend to be overloaded, TCP
transport is strongly recommended, but unfortunately this is restricted
to mostly 4.4BSD servers.
OpenBSD 3.6 March 29, 1995 3