MOUNT_LFS(8) BSD System Manager's Manual MOUNT_LFS(8)
mount_lfs - mount a log-structured file system
mount_lfs [-dns] [-o options] special node
The mount_lfs command attaches a log-structured file system special de-
vice on to the file system tree at the point node. In addition, the
lfs_cleanerd(8) utility is invoked to clean the file system periodically.
This command is normally executed by mount(8) at boot time.
The options are as follows:
-d Run lfs_cleanerd(8) in debug mode.
-o Options are specified with a -o flag followed by a comma separat-
ed string of options. See the mount(8) man page for possible op-
tions and their meanings.
-n Don't start lfs_cleanerd(8) on the file system.
-s Cause lfs_cleanerd(8) to read data in small chunks when cleaning
the file system.
mount(2), unmount(2), fstab(5), lfs_cleanerd(8), mount(8)
Ousterhout and Douglis, "Beating the I/O Bottleneck: A Case for Log-
structured File Systems", Operating Systems Review, No. 1, Vol. 23, pp.
11-27, 1989, also available as Technical Report UCB/CSD 88/467.
Rosenblum and Ousterhout, "The Design and Implementation of a Log-
Structured File System", ACM SIGOPS Operating Systems Review, No. 5, Vol.
Seltzer, "File System Performance and Transaction Support", PhD Thesis,
University of California, Berkeley, 1992, also available as Technical
Report UCB/ERL M92.
Seltzer, Bostic, McKusick and Staelin, "An Implementation of a Log-
Structured File System for UNIX", Proc. of the Winter 1993 USENIX Conf.,
pp. 315-331, 1993.
The mount_lfs function first appeared in 4.4BSD.
4.4BSD March 30, 1994 1