MOUNT_KERNFS(8) OpenBSD System Manager's Manual MOUNT_KERNFS(8)
mount_kernfs - mount the /kern file system
mount_kernfs [-o options] /kern mount_point
The mount_kernfs command attaches an instance of the kernel parameter
namespace to the global filesystem namespace. The conventional mount
point is /kern. This command is invoked by mount(8) when using the syn-
mount [options] -t kernfs /kern mount_point
This command is normally executed by mount(8) at boot time.
The filesystem includes several regular files which can be read, some of
which can also be written. The contents of the files are in a machine-
independent format, either a string, or an integer in decimal ASCII.
Where numbers are returned, a trailing newline character is also added.
The options are as follows:
Options are specified with a -o flag followed by a comma separat-
ed string of options. See the mount(8) man page for possible op-
tions and their meanings.
Statistics reported by df(1) on the /kern filesystem will indicate the
amount of unwired/physical memory instead of `disk space', and the number
of vnodes used/allocated instead of `inodes'. The filesystem's block
size is the system's page size.
boottime Time at which the system was last booted (decimal ASCII).
byteorder _BYTE_ORDER for this kernel.
copyright Kernel copyright message.
hostname The hostname, with a trailing newline. The hostname can be
changed by writing to this file. A trailing newline will be
stripped from the hostname being written.
The domainname, with a trailing newline. Behaves like a host-
hz Frequency of the system clock (decimal ASCII).
ipsec The currently configured IPsec Security Associations.
loadavg The 1, 5 and 15 minute load average in kernel fixed-point for-
mat. The final integer is the fix-point scaling factor. All
numbers are in decimal ASCII.
machine Architecture this kernel was compiled for.
model Model of the processor this machine is running on.
msgbuf Kernel message buffer, also read by syslogd(8), through the
log device, and by dmesg(8).
ncpu Number of CPUs in this machine.
ostype OS type for this kernel ("OpenBSD").
osrelease OS release number.
osrev OS revision number (BSD from <sys/param.h>).
pagesize Machine pagesize (decimal ASCII).
posix _POSIX_VERSION for this kernel.
physmem Number of pages of physical memory in the machine (decimal
rootdev Root device.
rrootdev Raw root device.
time Second and microsecond value of the system clock. Both num-
bers are in decimal ASCII.
usermem Number of pages of physical memory available for user process-
version Kernel version string. The head line for /etc/motd can be
generated by running: ``sed 1q /kern/version''.
mount(2), fstab(5), dmesg(8), mount(8), syslogd(8), umount(8)
The mount_kernfs utility first appeared in 4.4BSD.
This filesystem may not be NFS-exported.
OpenBSD 3.6 March 27, 1994 2