MLXCONTROL(8) BSD System Manager's Manual MLXCONTROL(8)
mlxcontrol -- Mylex DAC-family RAID management utility
mlxcontrol <command> [args]
mlxcontrol status [-qv] [drive]
mlxcontrol rescan controller [controller ...]
mlxcontrol detach drive [drive ...]
mlxcontrol detach -a
mlxcontrol check drive
mlxcontrol config controller
mlxcontrol help command
The mlxcontrol utility provides status monitoring and management func-
tions for devices attached to the mlx(4) driver.
Controller names are of the form "mlxN" where N is the unit number of the
controller. Drive names are of the form "mlxdN" where N is the unit num-
ber of the drive. Do not specify the path to a device node.
status Print the status of controllers and system drives. If one or
more drives are specified, only print information about these
drives, otherwise print information about all controllers and
drives in the system. With the -v flag, display much more ver-
bose information. With the -q flag, do not print any output.
This command returns 0 if all drives tested are online, 1 if one
or more drives are critical and 2 if one or more are offline.
rescan Rescan one or more controllers for non-attached system drives
(e.g. drives that have been detached or created subsequent to
driver initialisation). If the -a flag is supplied, rescan all
controllers in the system.
detach Detach one or more system drives. Drives must be unmounted and
not opened by any other utility for this command to succeed. If
the -a flag is supplied, detach all system drives from the nomi-
check Initiate a consistency check and repair pass on a redundant sys-
tem drive (e.g. RAID1 or RAID5). The controller will scan the
system drive and repair any inconsistencies. This command
returns immediately; use the status command to monitor the
progress of the check.
rebuild Requires two arguments, controller and physdrive as specified in
the output of the status command. All system drives using space
on the physical drive physdrive are rebuilt, reconstructing all
data on the drive. Note that each controller can only perform
one rebuild at a time. This command returns immediately; use
the status command to monitor the progress of the rebuild.
config Print the current configuration from the nominated controller.
This command will be updated to allow addition/deletion of sys-
tem drives from a configuration in a future release.
help Print usage information for command.
The config command does not yet support modifying system drive configura-
Error log extraction is not yet supported.
The mlxcontrol utility was written by Michael Smith <msmithATFreeBSD.org>.
BSD April 10, 2000 BSD