MLD6QUERY(8) BSD System Manager's Manual MLD6QUERY(8)
mld6query -- send multicast listener query
mld6query [-dr] intface [maddr]
The mld6query utility sends an IPv6 multicast listener discovery (MLD)
query packet toward the specified multicast address, maddr, toward inter-
face intface. If you omit maddr, linklocal all nodes multicast
address(ff02::1) is used.
After sending a query, mld6query waits for replies for at most 10 sec-
onds. If a reply is returned, mld6query prints it with its type and then
waits for another reply.
This program is provided only for debugging. It is not necessary for
With -d, mld6query will transmit MLD done packet instead of MLD query
packet. With -r, similarly, MLD report packet will be transmitted. -dr
options are for debugging purposes only.
The program exits with 0 on success, non-zero on failures.
The mld6query utility first appeared in WIDE/KAME IPv6 protocol stack
The mld6query utility does not take care of multicast addresses which
have non link-local scope.
BSD May 17, 1998 BSD