MKUZIP(8) BSD System Manager's Manual MKUZIP(8)
mkuzip -- compress disk image for use with geom_uzip(4) class
mkuzip [-v] [-o outfile] [-s cluster_size] infile
The mkuzip utility compresses a disk image file in such a way that the
geom_uzip(4) class will be able to decompress resulting image in run-
time. This allows for significant reduction of size of disk image at the
expense of some CPU time required to decompress the data each time it is
read. Internally, operation is done in two phases as follows:
1. An infile image is split into clusters and each cluster compressed
2. Resulting set of compressed clusters along with headers allowing to
independently locate each individual cluster is written into output
The options are:
Name the output file outfile. The default is to use the input
name with the suffix .uzip.
Use cluster_size as the size of chunks the file being split up
into. Default value is 16384 bytes. The cluster_size should be
a multiple of 512 bytes.
-v Display verbose messages.
Compression ratio largely depends on the cluster size used. For large
cluster sizes (16K and higher), typical compression ratios are only 1-2%
less than those achieved with the gzip(1) utlity. However, it should be
kept in mind that larger cluster sizes lead to higher overhead in the
geom_uzip(4) class, as the class has to decompress the whole cluster even
if only several bytes from that cluster have to be read.
The mkuzip inserts tiny shell script at the beginning of the generated
image, which makes it possible to ``run'' the image just like any other
shell script. This script tries to load geom_uzip(4) class if it is not
loaded, configure image as an md(4) disk device using mdconfig(8) util-
ity, and automatically mount it using mount_cd9660(8) utility to the
mount point provided as a first argument.
gzip(1), zlib(3), geom(4), geom_uzip(4), md(4), mdconfig(8),
The mkuzip utility exits 0 on success, and >0 if an error occurs.
Maxim Sobolev <sobomaxATFreeBSD.org>
BSD September 10, 2004 BSD