MKPROTO(8) BSD System Manager's Manual MKPROTO(8)
mkproto - construct a prototype file system
mkproto special proto
Mkproto is used to bootstrap a new file system. First a new file system
is created using newfs(8). Mkproto is then used to copy files from the
old file system into the new file system according to the directions
found in the prototype file proto. The prototype file contains tokens
separated by spaces or new lines. The first tokens comprise the specifi-
cation for the root directory. File specifications consist of tokens
giving the mode, the user-id, the group id, and the initial contents of
the file. The syntax of the contents field depends on the mode.
The mode token for a file is a 6 character string. The first character
specifies the type of the file. (The characters -bcd specify regular,
block special, character special and directory files respectively.) The
second character of the type is either u or `-' to specify set-user-id
mode or not. The third is g or `-' for the set-group-id mode. The rest
of the mode is a three digit octal number giving the owner, group, and
other read, write, execute permissions, see chmod(1).
Two decimal number tokens come after the mode; they specify the user and
group ID's of the owner of the file.
If the file is a regular file, the next token is a pathname whence the
contents and size are copied.
If the file is a block or character special file, two decimal number to-
kens follow which give the major and minor device numbers.
If the file is a directory, mkproto makes the entries `.' and `..' and
then reads a list of names and (recursively) file specifications for the
entries in the directory. The scan is terminated with the token $.
A sample prototype specification follows:
d--777 3 1
usr d--777 3 1
sh ---755 3 1 /bin/sh
ken d--755 6 1
b0 b--644 3 1 0 0
c0 c--644 3 1 0 0
fs(5), dir(5), fsck(8), newfs(8)
There should be some way to specify links.
There should be some way to specify bad blocks.
Mkproto can only be run on virgin file systems. It should be possible to
copy files into existent file systems.
The mkproto command appeared in 4.2BSD.
4.2 Berkeley Distribution June 6, 1993 1