MKNOD(8) OpenBSD System Manager's Manual MKNOD(8)
mknod - build special file
mknod [-m mode] name [c | b] major minor
mknod [-m mode] name p
The mknod command creates device special files. Normally the shell
script /dev/MAKEDEV is used to create special files for commonly known
devices; it executes mknod with the appropriate arguments and can make
all the files required for the device.
The options are as follows:
Set the file mode. mode may be absolute or symbolic, as de-
scribed in chmod(1). In symbolic mode strings, the `+' and `-'
operators are interpreted relative to an assumed initial mode of
To make nodes manually, the arguments are:
name Device or FIFO name. For example ``sd'' for a SCSI disk or a
``pty'' for pseudo-devices. FIFOs may be named arbitrarily by
b | c | p
Type of device or FIFO. If the device is a block type device
such as a tape or disk drive which needs both cooked and raw spe-
cial files, the type is b. All other devices are character type
devices, such as terminal and pseudo devices, and are type c. A
FIFO (also known as a named pipe) is type p.
major The major device number is an integer number which tells the ker-
nel which device driver entry point to use. To learn what major
device number to use for a particular device, check the file
/dev/MAKEDEV to see if the device is known.
minor The minor device number tells the kernel which subunit the node
corresponds to on the device; for example, a subunit may be a
filesystem partition or a tty line.
Major and minor device numbers can be given in any format accept-
able to strtoul(3), so that a leading ``0x'' indicates a hexadec-
imal number, and a leading ``0'' will cause the number to be in-
terpreted as octal.
chmod(1), mkfifo(1), mkfifo(2), mknod(2), MAKEDEV(8)
A mknod command appeared in Version 6 AT&T UNIX.
OpenBSD 3.6 April 18, 1999 1