MKNOD(8) BSD System Manager's Manual MKNOD(8)
mknod - build special file
mknod name [c | b] major minor
The mknod command creates device special files. Normally the shell
script /dev/MAKEDEV is used to create special files for commonly known
devices; it executes mknod with the appropriate arguments and can make
all the files required for the device.
To make nodes manually, the four required arguments are:
name Device name, for example ``sd'' for a SCSI disk on an HP300 or a
``pty'' for pseudo-devices.
b | c Type of device. If the device is a block type device such as a
tape or disk drive which needs both cooked and raw special files,
the type is b. All other devices are character type devices, such
as terminal and pseudo devices, and are type c.
major The major device number is an integer number which tells the ker-
nel which device driver entry point to use. To learn what major
device number to use for a particular device, check the file
/dev/MAKEDEV to see if the device is known, or check the system
dependent device configuration file:
(for example device.hp300).
minor The minor device number tells the kernel which subunit the node
corresponds to on the device; for example, a subunit may be a
filesystem partition or a tty line.
A mknod command appeared in Version 6 AT&T UNIX.
4th Berkeley Distribution December 11, 1993 1