MBRLABEL(8) BSD System Manager's Manual MBRLABEL(8)
mbrlabel -- update disk label from MBR label(s)
mbrlabel [-fqrw] device
mbrlabel is used to update a NetBSD disk label from the Master Boot
Record (MBR) label(s) found on disks that were previously used on
DOS/Windows systems (or other MBR using systems).
mbrlabel scans the MBR contained in the very first block of the disk,
then walks through every extended partition found and generating addi-
tional partition entries for the disk from the MBRs found in those
Each MBR partition which does not have an equivalent partition in the
disk label (equivalent in having the same size and offset) is added to
the first free partition slot in the disk label. A free partition slot
is defined as one with an fstype of 'unused' and a size of zero ('0').
If there are not enough free slots in the disk label, a warning will be
The raw partition (typically partition c, but d on i386 and some other
platforms) is left alone during this process.
By default, the proposed changed disk label will be displayed and no disk
label update will occur.
-f Force an update, even if there has been no change.
-q Performs operations in a quiet fashion.
-w Update the in-core label if it has been changed.
-r In conjunction with -w, also update the on-disk label.
disklabel(8), dkctl(8), fdisk(8), mbr(8)
The mbrlabel command appeared in NetBSD 1.4.
BSD July 13, 2003 BSD