MAKEWHATIS(8) BSD System Manager's Manual MAKEWHATIS(8)
makewhatis -- create a whatis.db database
/usr/libexec/makewhatis [-C file] [-f] [manpath ...]
makewhatis strips the NAME lines from compiled or raw man(1) pages and
creates a whatis.db database for use in apropos(1), whatis(1) or with
man(1)'s -k option. Man pages compressed with compress(1) and gzip(1)
are uncompressed before processing.
When manpath is provided multiple times, the resulting database file is
generated in the first directory specified, and contains entries for all
If manpath is not provided, makewhatis parses /etc/man.conf and regener-
ates the whatis database files specified there. Each database file is
assumed to reside in the root of the appropriate man page hierarchy.
The options are as follows:
Use file (in man.conf(5) format) as configuration file instead of
the default, /etc/man.conf.
-f Don't spawn child processes to generate the individual database
files, but do all the work synchronously in the foreground.
whatis.db name of the whatis database
/etc/man.conf man(1) configuration file, used to get the location of
the whatis databases when makewhatis is called without
apropos(1), man(1), whatis(1), man.conf(5)
makewhatis first appeared in NetBSD 1.0, as a shell script written by
J.T. Conklin <jtcATNetBSD.org> and Thorsten Frueauf <frueaufATira.de>.
Further work was done by Matthew Green, Luke Mewburn and Chris Demetriou.
Matthias Scheler has reimplemented makewhatis in C in NetBSD 1.5.
Matthias Scheler <tronATNetBSD.org>
BSD March 8, 2002 BSD