LOGIN_PASSWD(8) OpenBSD System Manager's Manual LOGIN_PASSWD(8)
login_passwd - provide standard password authentication type
login_passwd [-s service] [-v wheel=yes|no] [-v lastchance=yes|no] user
The login_passwd utility is called by login(1), su(1), ftpd(8), and oth-
ers to authenticate the user with passwd-style authentication.
The user argument is the login name of the user to be authenticated.
The service argument specifies which protocol to use with the invoking
program. The allowed protocols are login, challenge, and response. (The
challenge protocol is silently ignored but will report success as passwd-
style authentication is not challenge-response based).
If the wheel argument is specified and is not set to ``yes'', then the
user will be rejected as not being in group ``wheel''. This is used by
If the lastchance argument is specified and is equal to ``yes'', then if
the user's password has expired, and it has not been expired longer than
``password-dead'' seconds (see login.conf(5)), the user will be able to
log in one last time to change the password.
login_passwd will prompt the user for a password and report back to the
invoking program whether or not the authentication was successful.
login(1), passwd(1), su(1), login.conf(5), ftpd(8)
OpenBSD 3.6 December 11, 2000 1