LOGIN_KERBEROS(8) OpenBSD System Manager's Manual LOGIN_KERBEROS(8)
login_krb5-or-pwd - provide KerberosV or password authentication type
login_krb5-or-pwd [-s service] [-v ignored] user [class]
The login_krb5-or-pwd program first attempts to authenticate the user via
KerberosV and, failing that, falls back to standard password authentica-
If KerberosV is not configured on the system, login_krb5-or-pwd is equiv-
alent to calling login_passwd(8). When root tries to login,
login_krb5-or-pwd skips KerberosV authentication, as this may give prob-
lems in case of a network failure.
The user argument is the user's name to be authenticated.
The service argument specifies which protocol to use with the invoking
program. The allowed protocols are login, challenge, and response. (The
challenge protocol is silently ignored but will report success as Ker-
berosV authentication is not challenge-response based).
The ignored argument is ignored for compatibility with other login
login_krb5-or-pwd will prompt the user for a password and report back to
the invoking program whether or not the authentication was successful.
login(1), passwd(1), su(1), login.conf(5), ftpd(8), login_krb5(8)
OpenBSD 3.6 December 11, 2000 1