LOGIN_KERBEROS(8) OpenBSD System Manager's Manual LOGIN_KERBEROS(8)
login_krb5 - provide KerberosV authentication type
login_krb5 [-s service] [-v ignored] user [class]
The login_krb5 utility implements the KerberosV authentication mechanism.
It is called by login(1), su(1), ftpd(8), and others to authenticate the
user with KerberosV.
The user argument is the user's name to be authenticated.
The service argument specifies which protocol to use with the invoking
program. The allowed protocols are login, challenge, and response. (The
challenge protocol is silently ignored but will report success as Ker-
berosV authentication is not challenge-response based).
The ignored argument is ignored for compatibility with other login
login_krb5 will prompt the user for a password and report back to the in-
voking program whether or not the authentication was successful.
login(1), passwd(1), su(1), login.conf(5), ftpd(8), login_krb5-or-pwd(8)
OpenBSD 3.6 December 11, 2000 1