LOCATE.UPDATEDB(8) OpenBSD System Manager's Manual LOCATE.UPDATEDB(8)
locate.updatedb - update locate database
locate.updatedb [--tmpdir=dir] [--fcodes=dbfile]
locate.updatedb updates the database used by locate(1). It is typically
run once a week by the /etc/weekly script.
The contents of the newly built database can be controlled by the
/etc/locate.rc file as well as the command line arguments.
The options are as follows:
Sets the directory temporary files are stored in.
Use the named file as the find codes database. If the file name
`-' is given, the database will be sent to standard output.
Sets the list of directories to be put in the database.
Sets the list of parent directories that should not go in the
A list of filesystem types to be traversed by find(1).
/etc/locate.rc configuration file
/var/db/locate.database default database
find(1), locate(1), weekly(8)
Woods, James A., "Finding Files Fast", ;login, 8:1, pp. 8-10, 1983.
OpenBSD 3.6 February 11, 1996 1