L2PING(8) BSD System Manager's Manual L2PING(8)
l2ping -- send L2CAP ECHO_REQUEST to remote devices
l2ping [-fhn] -a remote [-c count] [-i delay] [-S source] [-s size]
The l2ping utility uses L2CAP ECHO_REQUEST datagram to elicit an L2CAP
ECHO_RESPONSE datagram from a remote device.
The options are as follows:
Specify the remote device to ping. The remote device can be
specified by either its BD_ADDR or name. If name was specified
then the l2ping utility will attempt to resolve the name via
Number of packets to send. If this option is not specified,
l2ping will operate until interrupted.
-f ``Flood'' ping, i.e., no delay between packets.
-h Display usage message and exit.
Wait wait seconds between sending each packet. The default is to
wait for one second between each packet. This option is ignored
if -f has been specified.
-n Numeric output only. No attempt will be made to look up symbolic
names for host addresses.
Specify the local device which should be used to send L2CAP
ECHO_REQUEST datagrams. The local device can be specified by
either its BD_ADDR or name. If name was specified then the
l2ping utility will attempt to resolve the name via
Specify the number of payload bytes to be sent. The default size
is 44 bytes. It is calculated as minimum L2CAP MTU (48 bytes)
minus the size of the L2CAP signalling command header (4 bytes).
The maximum size is 65531 bytes. Is is calculated as maximum
L2CAP MTU (65535 bytes) minus four bytes of payload reserved for
l2ping internal use. Use this option with caution. Some imple-
mentations may not like large sizes and may hang or even crash.
Could collect more statistic. Could check for duplicated, corrupted and
The l2ping utility exits 0 on success, and >0 if an error occurs.
bluetooth(3), netgraph(3), netgraph(4), ng_l2cap(4), l2control(8)
Maksim Yevmenkin <m_evmenkinATyahoo.com>
BSD June 14, 2002 BSD