KLDUNLOAD(8) BSD System Manager's Manual KLDUNLOAD(8)
kldunload -- unload a file from the kernel
kldunload [-f] [-fv] -i id
kldunload [-f] [-fv] [-n] name
The kldunload utility unloads a file which was previously loaded with
The following options are available:
-f Force the unload. This ignores error returns to MOD_QUIESCE
from the module and implies that the module should be unloaded
even if it is currently in use. The users are left to cope as
best they can.
-v Be more verbose.
-i id Unload the file with this ID.
-n name Unload the file with this name.
name Unload the file with this name.
The kldunload utility exits with a status of 0 on success and with a
nonzero status if an error occurs.
kldunload(2), kldload(8), kldstat(8)
The kldunload utility first appeared in FreeBSD 3.0, replacing the lkm(4)
Doug Rabson <dfrATFreeBSD.org>
BSD July 13, 2004 BSD