KLDCONFIG(8) BSD System Manager's Manual KLDCONFIG(8)
kldconfig -- display or modify the kernel module search path
kldconfig [-dfimnUv] [-S name] [path ...]
The kldconfig utility displays or modifies the search path used by the
kernel when loading modules using the kldload(8) utility or the
The following options are available:
-d Remove the specified paths from the module search path.
-f Do not display a diagnostic message if a path specified for
adding is already present in the search path, or if a path speci-
fied for removing is not present in the search path. This may be
useful in startup/shutdown scripts for adding a path to a file
system which is still not mounted, or in shutdown scripts for
unconditionally removing a path that may have been added during
-i Add the specified paths to the beginning of the search path, not
to the end. This option can only be used when adding paths.
-m Instead of replacing the module search path with the set of paths
specified, ``merge'' in the new entries.
-n Do not actually change the module search path.
-r Display the current search path. This option cannot be used if
any paths are also specified.
Specify the sysctl name to use instead of the default
-U ``Unique-ify'' the current search path - if any of the directo-
ries is repeated one or more times, only the first occurrence
remains. This option implies -m.
-v Verbose output: display the new module search path. If the path
has been changed, and the -v flag is specified more than once,
the old path is displayed as well.
/boot/kernel, /boot/modules, /modules
The default module search path used by the kernel.
The kldconfig utility exits with a status of 0 on success and with a
nonzero status if an error occurs.
kldload(2), kldload(8), sysctl(8)
The kldconfig utility first appeared in FreeBSD 4.4.
Peter Pentchev <roamATFreeBSD.org>
BSD June 15, 2001 BSD