KGMON(8) OpenBSD System Manager's Manual KGMON(8)
kgmon - generate a dump of the operating system's profile buffers
kgmon [-bhpr] [-M core] [-N system]
kgmon is a tool used when profiling the operating system. When no argu-
ments are supplied, kgmon indicates the state of operating system profil-
ing as ``running'', ``off'', or ``not configured'' (see config(8)). If
the -p flag is specified, kgmon extracts profile data from the operating
system and produces a gmon.out file suitable for later analysis by
The options are as follows:
-b Resume the collection of profile data.
-h Stop the collection of profile data.
-p Dump the contents of the profile buffers into a gmon.out file.
-r Reset all the profile buffers. If the -p flag is also specified,
the gmon.out file is generated before the buffers are reset.
-M Extract values associated with the name list from the specified
core instead of the default /dev/kmem.
-N Extract the name list from the specified system instead of the
If neither -b nor -h is specified, the state of profiling collection re-
mains unchanged. For example, if the -p flag is specified and profile
data is being collected, profiling will be momentarily suspended, the op-
erating system profile buffers will be dumped, and profiling will be im-
/bsd default system
/dev/kmem default memory
Users with only read permission on /dev/kmem cannot change the state of
profiling collection. They can get a gmon.out file with the warning that
the data may be inconsistent if profiling is in progress.
The kgmon command appeared in 4.2BSD.
OpenBSD 3.6 June 6, 1993 1