KDB_EDIT(8) BSD System Manager's Manual KDB_EDIT(8)
kdb_edit - Kerberos key distribution center database
kdb_edit [ -n ]
kdb_edit is used to create or change principals stored in
the Kerberos key distribution center (KDC) database.
When executed, kdb_edit prompts for the master key string
and verifies that it matches the master key stored in the
database. If the -n option is specified, the master key
is instead fetched from the master key cache file.
Once the master key has been verified, kdb_edit begins a
prompt loop. The user is prompted for the principal and
instance to be modified. If the entry is not found the
user may create it. Once an entry is found or created,
the user may set the password, expiration date, maximum
ticket lifetime, and attributes. Default expiration
dates, maximum ticket lifetimes, and attributes are pre-
sented in brackets; if the user presses return the default
is selected. There is no default password. The password
RANDOM is interpreted specially, and if entered the user
may have the program select a random DES key for the prin-
Upon successfully creating or changing the entry, ``Edit
O.K.'' is printed.
"verify_master_key: Invalid master key, does not match
The master key string entered was
DBM files containing database
Master key cache file.
MIT Project Athena Kerberos Version 4.0 1