ISPCVT(8) BSD System Manager's Manual ISPCVT(8)
ispcvt -- verify if current video driver is pcvt driver
ispcvt [-c] [-d device] [-n] [-v]
The ispcvt utility allows the user to check whether the current video
driver compiled into the kernel is a pcvt driver. The major and minor
release numbers of the driver are also checked. Furthermore ispcvt is
also able to print out the values of all the ``PCVT_XXXXXX'' compile time
options, the driver in the current running kernel was compiled with.
The options are as follows:
-d Specifies a device for which the check is done.
-v Specifies being verbose. On success the name and revision is
reported, on failure which comparison failed.
-n print the number of compiled-in virtual terminals.
-c This options prints out the values of all ``PCVT_XXXXXX''
#defines which were given to the compiler at the time the cur-
rently running kernel was compiled. Specifying -v with the -c
option gives a verbose listing of the compile-time options.
The ispcvt utility exits with one of the following values:
0 driver is pcvt and major and minor numbers match
1 open(2) or ioctl(2) system call failed
2 driver name mismatch
3 name matched, release major number mismatch
4 name and major number matched, release minor number mismatch
5 usage error
BSD March 27, 2000 BSD