ISDNDECODE(8) BSD System Manager's Manual ISDNDECODE(8)
isdndecode -- isdn4bsd ISDN protocol decode utility
isdndecode [-a] [-b] [-d] [-f filename] [-h] [-i] [-l] [-o] [-p filename]
[-u number] [-x] [-B] [-P] [-R unit] [-T unit]
The isdndecode utility is part of the isdn4bsd package and is used to
provide the user with a detailed mnemonic display of the layers 1, 2 and
3 protocol activities on the D channel and hex dump of the B channel(s)
Together with two passive supported cards and an easy to build cable it
can also be used to monitor the complete traffic on a S0 bus providing S0
bus analyzer features.
The isdndecode utility is only available for passive supported cards.
The following options can be used:
-a Run isdndecode in analyzer mode by using two passive cards and a
custom cable which can be build as described in the file
cable.txt in the isdn4bsd source distribution. One card acts as
a receiver for the transmitting direction on the S0 bus while the
other card acts as a receiver for the receiving direction on the
S0 bus. Complete traffic monitoring is possible using this set-
-b switch B channel tracing on (default off).
-d switch D channel tracing off (default on).
-f Use filename as the name of a file into which to write tracing
output (default filename is isdndecode<n> where n is the number
of the unit to decode).
-h switch display of header off (default on).
-i print layer 1 (I.430) INFO signals to monitor layer 1 activity
-l switch displaying of Layer 2 (Q.921) frames off (default on).
-o switch off writing decode output to a file (default on).
-p Use filename as the name of a file used for the -B and -P options
(default filename is isdntracebin<n> where n is the number of the
unit to decode).
-u Use number as the unit number of the controller card to decode
-x Decode Layer 3 packets with an unknown protocol discriminator.
-B Write undecoded binary decode data to a file for later or remote
analyzing (default off).
-P Read undecoded binary decode data from file instead from device
-R Use unit as the receiving interface unit number in analyze mode.
-T Use unit as the transmitting interface unit number in analyze
When the USR1 signal is sent to a isdndecode process, the currently used
logfiles are reopened, so that logfile rotation becomes possible.
The decode output should be obvious. It is very handy to have the fol-
lowing standard texts available when tracing ISDN protocols:
I.430 ISDN BRI layer 1 protocol description.
Q.921 ISDN D-channel layer 2 protocol description.
Q.931 ISDN D-channel layer 3 protocol description.
The devicefile(s) used to get the decode messages for ISDN card
unit <n> out of the kernel.
isdndecode -f /var/tmp/isdn.decode
will start D channel tracing on passive controller 0 with all except B
channel tracing enabled and logs everything into the output file
Still one left.
ITU Recommendations I.430, Q.920, Q.921, Q.930, Q.931
ITU Recommendation Q.932 (03/93), Q.950 (03/93)
ETSI Recommendation ETS 300 179 (10/92), ETS 300 180 (10/92)
ETSI Recommendation ETS 300 181 (04/93), ETS 300 182 (04/93)
ITU Recommendation X.208, X.209
The isdndecode utility and this manual page were written by Hellmuth
BSD February 21, 2000 BSD