IOSTAT(8) OpenBSD System Manager's Manual IOSTAT(8)
iostat - report I/O statistics
iostat [-CdDIT] [-c count] [-M core] [-N system] [-w wait] [drives]
iostat displays kernel I/O statistics on terminal, disk and CPU opera-
tions. By default, iostat displays one line of statistics averaged over
the machine's run time. The use of -c presents successive lines averaged
over the wait period. The -I option causes iostat to print raw, unaver-
The options are as follows:
-c Repeat the display count times. Unless the -I flag is in effect,
the first display is for the time since a reboot and each subse-
quent report is for the time period since the last display. If
no wait interval is specified, the default is 1 second.
-C Show CPU statistics. This is enabled by default unless the -d,
-D, or -T flags are used.
-d Show disk statistics. This is the default. Displays kilobytes
per transfer, number of transfers, and megabytes transferred.
Use of this flag disables display of CPU and tty statistics.
-D Show alternate disk statistics. Displays kilobytes transferred,
number of transfers, and time spent in transfers. Use of this
flag disables the default display.
-I Show the running total values, rather than an average.
-M Extract values associated with the name list from the specified
core instead of the default ``/dev/mem''.
-N Extract the name list from the specified system instead of the
-T Show tty statistics. This is enabled by default unless the -C,
-d, or -D flags are used.
-w Pause wait seconds between each display. If no repeat count is
specified, the default is infinity.
iostat displays its information in the following format:
tin characters read from terminals
tout characters written to terminals
Disk operations. The header of the field is the disk name and unit
number. If more than four disk drives are configured in the sys-
tem, iostat displays only the first four drives. To force iostat
to display specific drives, their names may be supplied on the com-
KB/t Kilobytes transferred per disk transfer
t/s Transfers per second
MB/s Megabytes transferred per second
The alternate display format, (selected with -D), presents the fol-
KB Kilobytes transferred
xfr Disk transfers
time Seconds spent in disk activity
us % of CPU time in user mode
ni % of CPU time in user mode running niced processes
sy % of CPU time in system mode
in % of CPU time processing interrupts
id % of CPU time in idle mode
/bsd default kernel namelist
/dev/mem default memory file
fstat(1), netstat(1), nfsstat(1), ps(1), systat(1), pstat(8), vmstat(8)
The sections starting with ``Interpreting system activity'' in Installing
and Operating 4.3BSD.
OpenBSD 3.6 January 18, 1996 2