IFCONFIG(8) OpenBSD System Manager's Manual IFCONFIG(8)
ifconfig - configure network interface parameters
ifconfig interface [address_family] [address [dest_address]] [parameters]
ifconfig -A | -Am | -a | -am [address_family]
ifconfig -m interface [address_family]
ifconfig interface create
ifconfig interface destroy
ifconfig carp-interface vhid host-id
ifconfig pfsync-interface syncpeer peer_address syncif iface
ifconfig tunnel-interface tunnel src_address dest_address
ifconfig tunnel-interface deletetunnel
ifconfig vlan-interface vlan vlan-tag vlandev parent-interface
ifconfig interface group group-name
The ifconfig utility is used to assign an address to a network interface
and/or configure network interface parameters. ifconfig must be used at
boot-time to define the network address of each interface present on a
machine; it may also be used at a later time to redefine an interface's
address or other operating parameters. To configure a bridge interface,
use the brconfig(8) program instead.
ifconfig displays the current configuration for a network interface when
no optional parameters are supplied. If a protocol family is specified,
ifconfig will report only the details specific to that protocol family.
Only the superuser may modify the configuration of a network interface.
The options are as follows:
-A Causes full interface alias information for each interface to be
-Am The same as the -A option, but additionally prints interface me-
dia information for all interfaces.
-a Causes ifconfig to print information on all interfaces. The pro-
tocol family may be specified as well.
-am The same as the -a option, but additionally prints interface me-
dia information for all interfaces.
-C Print the names of all network pseudo-devices that can be created
dynamically at runtime using ifconfig create.
Print media information for a given interface.
For the DARPA Internet family, the address is either a host name
present in the host name database, hosts(5), or a DARPA Internet
address expressed in the Internet standard ``dot notation''.
Internet version 6 addresses are either a host name present in
the host name database, hosts(5), or an Internet version 6 ad-
dress in standard colon separated form, as described in the
inet(3) manual page.
For the Xerox Network Systems(tm) and Internetwork Packet Ex-
change families, addresses are of the form ``net:a.b.c.d.e.f'',
where ``net'' is the assigned network number (in decimal), and
each of the six bytes of the host number, ``a'' through ``f'',
are specified in hexadecimal. The host number may be omitted on
Ethernet interfaces, which use the hardware physical address, and
on interfaces other than the first.
AppleTalk (LLAP) addresses are specified as ``nn.na'' (``Network
Number.Node Address''). Node addresses are divided into two
classes: User Node IDs and Server Node IDs. 1-127($01-$7F) are
for User Node IDs while 128-254($80-$FE) are used for Server Node
IDs. Node 0($00) is not allowed (unknown) while Node 255($FF) is
reserved for the AppleTalk broadcast hardware address (broadcast
IPX addresses are specified as listed in the ipx(3) manual page.
Specifies the address family which affects interpretation of the
remaining parameters. Since an interface can receive transmis-
sions in differing protocols with different naming schemes, spec-
ifying the address family is recommended. The address or proto-
col families currently supported are ``inet'', ``inet6'',
``atalk'', ``ipx'', and ``ns''.
The interface parameter is a string of the form ``name unit'',
for example, ``en0''. If no optional parameters are supplied,
this string can instead be just ``name''. In this case, all in-
terfaces of that type will be displayed. For example, ``carp''
will display the current configuration of all carp(4) interfaces.
The following parameters may be set with ifconfig:
802.2 802.2tr 802.3 snap EtherII
Set the ipx(3) frame type to be either 802.2, 802.2tr,
802.3, snap, or Ethernet II.
advbase n If the driver is a carp(4) pseudo-device, set the base
advertisement interval to n seconds. This is an 8-bit
number; the default value is 1 second.
advskew n If the driver is a carp(4) pseudo-device, skew the adver-
tisement interval by n. This is an 8-bit number; the de-
fault value is 0.
Taken together the advbase and advskew indicate how fre-
quently, in seconds, the host will advertise the fact
that it considers itself master of the virtual host. The
formula is advbase + (advskew / 255 ). If the master
does not advertise within three times this interval, this
host will begin advertising as master.
alias Establish an additional network address for this inter-
face. This is sometimes useful when changing network
numbers, and one wishes to accept packets addressed to
the old interface.
-alias Remove the specified network address alias.
anycast (inet6 only) Set the IPv6 anycast address bit.
-anycast (inet6 only) Clear the IPv6 anycast address bit.
arp Enable the use of the Address Resolution Protocol
(``ARP''; see arp(4)) in mapping between network level
addresses and link level addresses (default). This is
currently implemented for mapping between DARPA Internet
addresses and Ethernet addresses.
-arp Disable the use of ARP.
broadcast addr (inet only) Specify the address to use to represent
broadcasts to the network. The default broadcast address
is the address with a host part of all 1's.
create Create the specified network pseudo-device. At least the
following devices can be created on demand:
bridge(4), carp(4), gif(4), gre(4), lo(4), ppp(4), sl(4),
debug Enable driver-dependent debugging code; usually, this
turns on extra console error logging.
-debug Disable driver-dependent debugging code.
delete Remove the network address specified. This would be used
if you incorrectly specified an alias, or it was no
longer needed. If you have incorrectly set an NS address
having the side effect of specifying the host portion,
removing all NS addresses will allow you to respecify the
deletetunnel Removes the source and destination tunnel addresses, con-
figured onto a tunnel interface.
Specify a description of the interface. This can be used
to label interfaces in situations where they may other-
wise be difficult to distinguish.
dest_address Specify the address of the correspondent on the other end
of a point-to-point link.
destroy Destroy the specified network pseudo-device.
down Mark an interface ``down''. When an interface is marked
``down'', the system will not attempt to transmit mes-
sages through that interface. If possible, the interface
will be reset to disable reception as well. This action
automatically disables routes using the interface.
Assign the interface to a ``group''. Any interface can
be in multiple groups. Interface groups are described in
Remove the interface from the given ``group''.
eui64 (inet6 only) Fill the interface index (the lowermost 64th
bit of an IPv6 address) automatically.
instance minst Set the media instance to minst. This is useful for de-
vices which have multiple physical layer interfaces
(PHYs). Setting the instance on such devices may not be
strictly required by the network interface driver as the
driver may take care of this automatically; see the driv-
er's manual page for more information.
ipdst addr This is used to specify an Internet host which is willing
to receive IP packets encapsulating NS packets bound for
a remote network. An apparent point-to-point link is
constructed, and the address specified will be taken as
the NS address and network of the destination. IP encap-
sulation of Connectionless Network Protocol (``CLNP'')
packets is done differently.
link[0-2] Enable special processing of the link level of the inter-
face. These three options are interface specific in ac-
tual effect; however, they are in general used to select
special modes of operation. An example of this is to en-
able SLIP compression, or to select the connector type
for some Ethernet cards. Refer to the man page for the
specific driver for more information.
-link[0-2] Disable special processing at the link level with the
maxupd n If the driver is a pfsync(4) pseudo-device, indicate the
maximum number of updates for a single state which can be
collapsed into one. This is an 8-bit number; the default
value is 128.
media type Set the media type of the interface to type. Some inter-
faces support the mutually exclusive use of one of sever-
al different physical media connectors. For example, a
10Mb/s Ethernet interface might support the use of either
AUI or twisted pair connectors. Setting the media type
to ``10base5'' or ``AUI'' would change the currently ac-
tive connector to the AUI port. Setting it to
``10baseT'' or ``UTP'' would activate twisted pair. Re-
fer to the interface's driver-specific man page for a
complete list of the available types, or use
$ ifconfig -m interface
for a listing of choices.
mediaopt opts Set the specified media options on the interface. opts
is a comma delimited list of options to apply to the in-
terface. Refer to the interface's driver-specific man
page for a complete list of available options, or use
$ ifconfig -m interface
for a listing of choices.
-mediaopt opts Disable the specified media options on the interface.
metric nhops Set the routing metric of the interface to nhops, default
0. The routing metric is used by the routing protocol
(see routed(8)). Higher metrics have the effect of mak-
ing a route less favorable; metrics are counted as addi-
tion hops to the destination network or host.
mtu value Set the MTU for this device to the given value. Cloned
routes will inherit this value as a default.
netmask mask (inet and inet6) Specify how much of the address to re-
serve for subdividing networks into subnetworks. The
mask includes the network part of the local address and
the subnet part, which is taken from the host field of
the address. The mask can be specified as a single hex-
adecimal number with a leading 0x, with a dot-notation
Internet address, or with a pseudo-network name listed in
the network table networks(5). The mask contains 1's for
the bit positions in the 32-bit address which are to be
used for the network and subnet parts, and 0's for the
host part. The mask should contain at least the standard
network portion, and the subnet field should be contigu-
ous with the network portion.
nwid id (IEEE 802.11 devices only) Configure network ID for IEEE
802.11-based wireless network interfaces. The id can ei-
ther be any text string up to 32 characters in length, or
a series of hexadecimal digits up to 64 digits. The emp-
ty string allows the interface to connect to any avail-
able access points.
nwkey key (IEEE 802.11 devices only) Enable WEP encryption for IEEE
802.11-based wireless network interfaces using the speci-
fied key. The key can either be a string, a series of
hexadecimal digits (preceded by `0x'), or a set of keys
of the form ``n:k1,k2,k3,k4'' where `n' specifies which
of the keys will be used for transmitted packets, and the
four keys, ``k1'' through ``k4'', are configured as WEP
keys. If a set of keys is specified, a comma (`,') with-
in the key must be escaped with a backslash. Note that
if multiple keys are used, their order must be the same
within the network. For IEEE 802.11 wireless networks,
the length of each key is restricted to 40 bits, i.e. a
5-character string or 10 hexadecimal digits. Wave-
LAN/IEEE Gold and newer Prism cards will also accept a
104-bit (13-character) key.
-nwkey (IEEE 802.11 devices only) Disable WEP encryption for
IEEE 802.11-based wireless network interfaces.
nwkey persist (IEEE 802.11 devices only) Enable WEP encryption for IEEE
802.11-based wireless network interfaces with the persis-
tent key stored in the network card.
(IEEE 802.11 devices only) Write key to the persistent
memory of the network card, and enable WEP encryption for
IEEE 802.11-based wireless network interfaces using that
If the driver is a carp(4) pseudo-device, set the authen-
tication key to passphrase. There is no passphrase by
phase n The argument n specifies the version (phase) of the Ap-
pleTalk network attached to the interface. Values of 1
or 2 are permitted.
pltime n (inet6 only) Set preferred lifetime for the address.
powersave (IEEE 802.11 devices only) Enable 802.11 power saving
-powersave (IEEE 802.11 devices only) Disable 802.11 power saving
(IEEE 802.11 devices only) Set the receiver sleep dura-
tion (in milliseconds) for 802.11 power saving mode.
prefixlen n (inet and inet6 only) Effect is similar to netmask, but
you can specify prefix length by digits.
range netrange Under AppleTalk, set the interface to respond to a
netrange of the form ``startnet-endnet''. AppleTalk uses
this scheme instead of netmasks though OpenBSD implements
it internally as a set of netmasks.
state state Explicitly force the carp(4) pseudo-device to enter this
state. Valid states are init, backup, and master.
If the driver is a pfsync(4) pseudo-device, make the pf-
sync link point-to-point rather than using multicast to
broadcast the state synchronisation messages. The
peer_address is the IP address of the other host taking
part in the pfsync cluster. With this option, pfsync(4)
traffic can be protected using ipsec(4).
-syncpeer If the driver is a pfsync(4) pseudo-device, broadcast the
packets using multicast.
syncif iface If the driver is a pfsync(4) pseudo-device, use the spec-
ified interface to send and receive pfsync state synchro-
-syncif If the driver is a pfsync(4) pseudo-device, stop sending
pfsync state synchronisation messages over the network.
tentative (inet6 only) Set the IPv6 tentative address bit.
-tentative (inet6 only) Clear the IPv6 tentative address bit.
Set the timeslot range map, which is used to control
which channels an interface device uses.
tunnel src_address dest_address
Set the source and destination tunnel addresses on a tun-
nel interface, including gif(4). Packets routed to this
interface will be encapsulated in IPv4 or IPv6, depending
on the source and destination address families. Both ad-
dresses must be of the same family.
up Mark an interface ``up''. This may be used to enable an
interface after an ifconfig down. It happens automati-
cally when setting the first address on an interface. If
the interface was reset when previously marked down, the
hardware will be re-initialized.
vhid n If the driver is a carp(4) pseudo-device, set the virtual
host ID to n. Acceptable values are 1 to 255.
vlan vlan_tag If the interface is a vlan(4) pseudo-interface, set the
vlan tag value to vlan_tag. This value is a 12-bit num-
ber which is used to create an 802.1Q vlan header for
packets sent from the vlan interface. Note that vlan and
vlandev must both be set at the same time.
vlandev iface If the interface is a vlan(4) pseudo-device, associate
physical interface iface with it. Packets transmitted
through the vlan interface will be diverted to the speci-
fied physical interface iface with 802.1Q vlan encapsula-
tion. Packets with 802.1Q encapsulation received by the
parent interface with the correct vlan tag will be di-
verted to the associated vlan pseudo-interface. The vlan
interface is assigned a copy of the parent interface's
flags and the parent's Ethernet address. vlandev and
vlan must both be set at the same time. If the vlan in-
terface already has a physical interface associated with
it, this command will fail. To change the association to
another physical interface, the existing association must
be cleared first.
Note: if the link0 flag is set on the vlan interface, the
vlan pseudo-interface's behavior changes; link0 tells the
vlan interface that the parent interface supports inser-
tion and extraction of vlan tags on its own (usually in
firmware) and that it should pass packets to and from the
-vlandev If the driver is a vlan(4) pseudo-device, disassociate
the physical interface from it. This breaks the link be-
tween the vlan interface and its parent, clears its vlan
tag, flags, and link address, and shuts the interface
vltime n (inet6 only) Set valid lifetime for the address.
Assign the inet(3) address of 192.168.1.10 with a network mask of
255.255.255.0 to interface fxp0:
# ifconfig fxp0 inet 192.168.1.10 netmask 255.255.255.0
Assign the ipx(3) address of 12625920 specified in decimal to interface
# ifconfig fxp0 ipx 12625920
Assign the AppleTalk network 39108 and server node 128 with a network
range of 39107-39109 to interface fxp0 on a phase 2 AppleTalk network:
# ifconfig fxp0 atalk 39108.128 range 39107-39109 phase 2
Configure the xl0 interface to use 10baseT:
# ifconfig xl0 media 10baseT
Configure the xl0 interface to use 100baseTX, full duplex:
# ifconfig xl0 media 100baseTX mediaopt full-duplex
Label the em0 interface as an uplink:
# ifconfig em0 description "Uplink to Gigabit Switch 2"
Configure the vlan0 interface for IP address 192.168.254.1, vlan tag 4,
and vlan parent device fxp0:
# ifconfig vlan0 192.168.254.1 vlan 4 vlandev fxp0
Configure the carp0 interface for IP address 192.168.10.1, virtual host
# ifconfig carp0 vhid 1 192.168.10.1
Create the gif1 network interface:
# ifconfig gif1 create
Destroy the gif1 network interface:
# ifconfig gif1 destroy
Messages indicating the specified interface does not exist, the requested
address is unknown, or the user is not privileged and tried to alter an
netstat(1), inet(3), ipx(3), arp(4), bridge(4), carp(4), gif(4), gre(4),
ifmedia(4), inet(4), lo(4), netintro(4), pfsync(4), ppp(4), sl(4),
tun(4), vlan(4), hostname.if(5), hosts(5), networks(5), brconfig(8),
The ifconfig command appeared in 4.2BSD.
OpenBSD 3.6 September 3, 1998 8