IDENTD(8) BSD System Manager's Manual IDENTD(8)
identd -- TCP/IP Ident protocol server
identd [-46beIilNnr] [-a address] [-c charset] [-F format] [-f fallback]
[-g uid] [-L username] [-o osname] [-p portno] [-t seconds]
identd is a TCP/IP server which implements the user identification proto-
col as specified in RFC 1413.
identd operates by looking up specific TCP/IP connections and returning
information which may or may not be associated with the process owning
The following options are available:
-4 Bind to IPv4 addresses only. (flag -b only)
-6 Bind to IPv6 addresses only. (flag -b only)
-a address Bind to the specified address. This may be an IPv4 or
IPv6 address or even a hostname. If a hostname is speci-
fied then identd will resolve it to an address (or
addresses) and will bind this address. (flag -b only)
-b Run in the background (as daemon).
-c charset Specfify an optional character set designator to be
included in replies. charset should be a valid charset
set as described in the MIME RFC in upper case charac-
-e Return ``UNKNOWN-ERROR'' instead of the usual ``NO-USER''
or ``INVALID-PORT'' error replies.
-F format Specify the format to display info. The allowed format
%u print user name
%U print user number
%g print (primary) group name
%G print (primary) group number
%l print list of all groups by name
%L print list of all groups by number
The lists of groups (%l, %L) are comma-separated, and
start with the primary group which is not repeated. Any
other characters (preceded by %, and those not preceded
by it) are printed literally. The ``default'' format is
%u, and you should not use anything else without using
the flag -o OTHER.
-f fallback Specify a fallback username. If the lookup fails then
this username will be returned. This can be useful for
when running this service on a NAT host.
-g gid Specify the group id number or name which the server
should switch to after binding itself to the TCP/IP port.
-I Same as -i but without the restriction that the username
in .ident must not match an existing user.
-i If the .ident file exists in the home directory of the
identified user, return the username found in that file
instead of the real username. If the username found in
.ident is that of an existing user, then the real user-
name will be returned.
-L username Specify a ``lie'' username. Return this name for all
-l Use syslogd(8) for logging.
-N Enable .noident files. If this file exists in the home
directory of the identified user then return
``HIDDEN-USER'' instead of the normal USERID response.
-n Return numeric user IDs instead of usernames.
-o osname Return osname instead of the default ``UNIX''.
-p portno Specify an alternative port number under which the server
should run. The default is port 113. (flag -b only)
-r Return a random name of alphanumeric characters. If the
-n flag is also enabled then a random number will be
-t seconds Specify a timeout for the service. The default timeout
is 30 seconds.
-u uid Specify the user id number or name to which the server
should switch after binding itself to the TCP/IP port.
identd operates from inetd(8) or as standalone daemon. Put the following
lines into inetd.conf(5) to enable identd as an IPv4 and IPv6 service via
ident stream tcp nowait nobody /usr/libexec/identd identd -l
ident stream tcp6 nowait nobody /usr/libexec/identd identd -l
If you want to run identd as standalone daemon then please use the -b
BSD January 31, 2004 BSD