IASL(8) BSD System Manager's Manual IASL(8)
iasl -- Intel ACPI compiler/decompiler
iasl [-cefghl] [-b type] [-d file] [-dc file] [-hc] [-hr] [-i type] [-ln]
[-ls] [-oa] [-of] [-oi] [-on] [-ot] [-p prefix] [-s type] [-t type]
[-vi] [-vo] [-vr] [-vs] [-x level] input-file
The iasl utility is a compiler/decompiler for ACPI Source Language (ASL)
and ACPI Machine Language (AML). Major features of iasl include:
o Full support for the ACPI 2.0b Specification including ASL
grammar elements and operators.
o Extensive compiler syntax and semantic error checking, espe-
cially in the area of control methods. This reduces the number
of errors that are not discovered until the AML code is actu-
ally interpreted (i.e., the compile-time error checking reduces
the number of run-time errors).
o Multiple types of output files, including formatted listing
files with intermixed source, several types of AML files, and
Create compiler debug/trace file (*.txt). Types:
-c Parse only, no output generation.
Disassemble AML to ASL source code file (*.dsl).
Disassemble AML and immediately compile it. (Obtain DSDT from
current system if no input file.)
-e Generate External() statements for unresolved symbols.
-f Ignore errors, force creation of AML output file(s).
-g Get ACPI tables and write to files (*.dat).
-h Additional help and compiler debug options.
-hc Display operators allowed in constant expressions.
-hr Display ACPI reserved method names.
-i a|c Create assembler or C include file (*.inc or *.h).
-l Create mixed listing file (ASL source and AML) (*.lst).
-ln Create namespace file (*.nsp).
-ls Create combined source file (expanded includes) (*.src).
-oa Disable all optimizations (compatibility mode).
-of Disable constant folding.
-oi Disable integer optimization to Zero/One/Ones.
-on Disable named reference string optimization.
-ot Display compile times.
Specify filename prefix for all output files (including .aml).
-s a|c Create AML in assembler or C source file (*.asm or *.c).
-t a|c Create AML in assembler or C hex table (*.hex).
-vi Less verbose errors and warnings for use with IDEs.
-vo Enable optimization comments.
-vr Disable remarks.
-vs Disable signon.
Set debug level for trace output.
The iasl utility is provided with Intel ACPI-CA. It first appeared in
The iasl utility was written by Intel. This manual page was written by
BSD August 7, 2003 BSD