HDAUDIOCTL(8) System Manager's Manual HDAUDIOCTL(8)
hdaudioctl -- program to manipulate hdaudio(4) devices.
hdaudioctl [-f device] command [arguments]
The hdaudioctl command can be used to inspect and reconfigure High
Definition Audio devices and their child codecs.
The mandatory command argument specifies the action to take. Valid
list For each child codec of the chosen hdaudio(4) device,
display the nid, vendor, product, subsystem and device
get codecid nid Retrieve and display the current codec configuration
as a proplib(3) XML plist.
set codecid nid [plist]
Detach the specified hdafg(4) codec and then re-attach
with its widgets explicitly configured according to
the specified plist. If no plist is given, the in-
built widget parsing rules based on the High
Definition Audio specification will be used.
graph codecid nid Output a DOT file suitable processing by graphviz.
The resulting image will graphically show the
structure and interconnections of the widgets that
form the chosen hdafg(4) codec.
/dev/hdaudioX control devices
audio(4), hdaudio(4), pkgsrc/graphics/graphviz
The hdaudioctl command first appeared in NetBSD 5.1.
hdaudioctl is based on two separate programs written by Jared McNeill
<jmcneillATNetBSD.org> under contract by
Precedence Technologies Ltd <http://www.precedence.co.uk/>. Integration
into one program and writing this manual page was done by
Stephen Borrill <sborrillATNetBSD.org>.
When a plist is loaded and the hdafg(4) codec reattaches, all mixer
controls will be returned to their default values.
NetBSD 6.1.5 October 6, 2009 NetBSD 6.1.5