REBOOT(8) BSD System Manager's Manual REBOOT(8)
reboot, poweroff, halt -- restarting, powering down and stopping the sys-
The poweroff, halt and reboot utilities flush the file system cache to
disk, send all running processes a SIGTERM, wait for several seconds for
them to die, send a SIGKILL to the survivors and, respectively, power
down, halt or restart the system. The action is logged, including enter-
ing a shutdown record into the login accounting file and sending a mes-
sage via syslog(3).
The options are as follows:
-d Create a dump before halting or restarting. This option is use-
ful for debugging system dump procedures or capturing the state
of a corrupted or misbehaving system.
-l Suppress sending a message via syslog(3) before halting or
-n Do not flush the file system cache. This option should be used
with extreme caution. It can be used if a disk or the processor
is on fire.
-p Attempt to powerdown the system. If the powerdown fails, or the
system does not support software powerdown, the system will halt.
This option is only valid for halt.
-q Do not give processes a chance to shut down before halting or
restarting. This option should not normally be used.
Normally, the shutdown(8) utility is used when the system needs to be
halted or restarted, giving users advance warning of their impending
reboot(2), syslog(3), utmp(5), boot(8), shutdown(8), sync(8)
A reboot command appeared in Version 6 AT&T UNIX.
The poweroff command first appeared in NetBSD 1.5.
Once the command has begun its work, stopping it before it completes will
probably result in a system so crippled it must be physically reset. To
prevent premature termination, the command blocks many signals early in
its execution. However, nothing can defend against deliberate attempts
to evade this.
The single user shell will ignore the SIGTERM signal. To avoid waiting
for the timeout when rebooting or halting from the single user shell, you
have to exec reboot or exec halt.
BSD April 4, 2003 BSD