GSTAT(8) BSD System Manager's Manual GSTAT(8)
gstat -- print statistics about GEOM disks
gstat [-cd] [-I interval]
The gstat utility can be used to monitor I/O transactions of geom(4)
The options are as follows:
-c Enable display of geom(4) consumers too. The default is to show
statistics only for geom(4) producers.
-d Enable display of statistics for delete (BIO_DELETE) operations.
Refresh the gstat display every interval microseconds. Adding a
suffix of s, ms, or us (the default) indicates that the update
interval is specified in seconds, milliseconds, or microseconds,
The gstat utility exits 0 on success, and >0 if an error occurs.
A gstat utility appeared in FreeBSD 5.0.
The gstat utility only works interactively. It should probably detect
when it is run non-interactively and produce simple ASCII text output.
Otherwise, this utility should probably be folded into systat(1) which
only works interactively and is the obvious utility to run for various
other forms of system statistics.
BSD March 3, 2003 BSD