GPT(8) BSD System Manager's Manual GPT(8)
gpt -- GUID partition table maintenance utility
gpt [general_options] command [command_options] device ...
The gpt utility provides the necessary functionality to manipulate GUID
partition tables (GPTs), but see BUGS below for how and where functional-
ity is missing. The basic usage model of the gpt tool follows that of
the cvs(1) tool. The general options are described in the following
paragraph. The remaining paragraphs describe the individual commands
with their options. Here we conclude by mentioning that a device is
either a special file corresponding to a disk-like device or a regular
file. The command is applied to each device listed on the command line.
The general options allow the user to change default settings or other-
wise change the behaviour that is applicable to all commands. Not all
commands use all default settings, so some general options may not have
an effect on all commands.
The -p count option allows the user to change the number of partitions
the GPT can accomodate. This is used whenever a new GPT is created. By
default, the gpt utility will create space for 128 partitions (or 32 sec-
tors of 512 bytes).
The -r option causes the gpt utility to open the device for reading only.
Currently this option is primarily useful for the show command, but the
intent is to use it to implement dry-run behaviour.
The -v option controls the verbosity level. The level increases with
every occurrence of this option. There is no formalized definition of
the different levels yet.
gpt add [-b number] [-i index] [-s count] [-t type] device ...
The add command allows the user to add a new partition to an
existing table. By default, it will create a UFS partition cov-
ering the first available block of an unused disk space. The
command-specific options can be used to control this behaviour.
The -b number option allows the user to specify the starting
(beginning) sector number of the partition. The minimum sector
number is 1, but has to fall inside an unused region of disk
space that is covered by the GPT.
The -i index option allows the user to specify which (free) entry
in the GPT table is to be used for the new partition. By
default, the first free entry is selected.
The -s count option allows the user to specify the size of the
partition in sectors. The minimum size is 1.
The -t type option allows the user to specify the partition type.
The type is given as an UUID, but gpt accepts efi, swap, ufs,
linux and windows as aliases for the most commonly used partition
gpt create [-fp] device ...
The create command allows the user to create a new (empty) GPT.
By default, one cannot create a GPT when the device contains a
MBR, however this can be overridden with the -f option. If the
-f option is specified, an existing MBR is destroyed and any par-
titions described by the MBR are lost.
The -p option tells gpt to create only the primary table and not
the backup table. This option is only useful for debugging and
should not be used otherwise.
gpt destroy [-r] device ...
The destroy command allows the user to destroy an existing, pos-
sibly not empty GPT.
The -r option instructs gpt to destroy the table in a way that it
can be recovered.
gpt migrate [-fs] device ...
The migrate command allows the user to migrate an MBR-based disk
partitioning into a GPT-based partitioning. By default, the MBR
is not migrated when it contains partitions of an unknown type.
This can be overridden with the -f option. Specifying the -f
option will cause unknown partitions to be ignored and any data
in it to be lost.
The -s option prevents migrating BSD disk labels into GPT parti-
tions by creating the GPT equivalent of a slice.
gpt remove [-b number] [-i index] [-s count] [-t type] device ...
The remove command allows the user to remove any partitions that
match the selection. BEWARE: when no options are given, all GPT
partitions will match and thus will be deleted.
The -b number option selects the partitions that starts at the
The -i index option selects the partition with the given parti-
The -s count option selects all partitions that have the given
size. This can cause multiple partitions to be removed.
The -t type option selects all partitions that have the given
type. The type is given as an UUID or by the aliases that the
add command accepts. This can cause multiple partitions to be
gpt show device ...
The show command displays the current partitioning on the listed
devices and gives an overall view of the disk contents.
fdisk(8), mount(8), newfs(8), swapon(8)
The gpt utility appeared in FreeBSD 5.0 for ia64.
The development of the gpt utility is still work in progress. Many nec-
essary features are missing or partially implemented. In practice this
means that the manual page, supposed to describe these features, is far-
ther removed from being complete or useful. As such, missing functional-
ity is not even documented as missing. However, it is believed that the
currently present functionality is reliable and stable enough that this
tool can be used without bullet-proof footware if one thinks one does not
It is expected that the basic usage model does not change, but it is pos-
sible that future versions will not be compatible in the strictest sense
of the word. For example, the -p count option may be changed to a com-
mand option rather than a generic option. There are only two commands
that use it so there is a chance that the natural tendency for people is
to use it as a command option. Also, options primarily intended for
diagnostic or debug purposes may be removed in future versions.
Another possibility is that the current usage model is accompanied by
other interfaces to make the tool usable as a back-end. This all depends
on demand and thus feedback.
BSD November 12, 2004 BSD