GETNAME(8) BSD System Manager's Manual GETNAME(8)
getNAME -- get NAME sections from manual source for whatis/apropos data
[-itvw] path [path ...]
The getNAME utility looks inside manual page sources to find the name of
the page. It can be used to create a table of contents, report the style
of manual, or to create an introductory manual page. By default, getNAME
returns data for use in an apropos(1) database. getNAME is designed to
be called from makewhatis(8) or other manual grovelling tools, not to be
The following options are available:
-i The -i option returns information useful in creating an introduc-
tion manual. See intro(1), intro(2), etc. for examples.
-t The -t option returns information useful for creating a table of
-v Complain about incorrectly formatted man pages.
-w The -w option determines whether traditional man (``OLD''), new
mandoc (``NEW''), or some unknown (``UNKNOWN'') macros are in
The getNAME command first appeared in 2.0BSD
It would be nice if getNAME could deal with compressed and/or preformat-
ted manual pages. Looks for .S[Hh] NAME for consistency checking, but
that breaks man pages in other languages.
man(1), catman(8), makewhatis(8)
NetBSD October 31, 1997 NetBSD