FSCK_MSDOS(8) BSD System Manager's Manual FSCK_MSDOS(8)
fsck_msdos -- DOS/Windows (FAT) file system consistency check
fsck_msdos -q special ...
fsck_msdos -p [-f] special ...
fsck_msdos [-fny] special ...
The fsck_msdos utility verifies and repairs FAT file systems (more com-
monly known as DOS file systems).
The first form of fsck_msdos quickly checks the specified file systems to
determine whether they were cleanly unmounted.
The second form of fsck_msdos preens the specified file systems. It is
normally started by fsck(8) run from /etc/rc.boot during automatic
reboot, when a FAT file system is detected. When preening file systems,
fsck_msdos will fix common inconsistencies non-interactively. If more
serious problems are found, fsck_msdos does not try to fix them, indi-
cates that it was not successful, and exits.
The third form of fsck_msdos checks the specified file systems and tries
to repair all detected inconsistencies, requesting confirmation before
making any changes. The default behavior is to always ask for confirma-
tion of each change. Use the -n or -y options to override this default
The options are as follows:
-q Causes fsck_msdos to quickly check whether the volume was
unmounted cleanly. If the volume was unmounted cleanly,
then the exit status is 0. If the volume was not unmounted
cleanly, then the exit status will be non-zero. In either
case, a message is printed to standard output describing
whether the volume was clean or dirty.
-f This option is ignored by fsck_msdos and is present only
for compatibility with programs that check other file sys-
tem types for consistency.
-n Causes fsck_msdos to assume no as the answer to all opera-
tor questions, except ``CONTINUE?''.
-p Preen the specified file systems.
-y Causes fsck_msdos to assume yes as the answer to all opera-
fsck_msdos is still under construction.
NetBSD August 13, 1995 NetBSD