FIXMOUNT(8) BSD System Manager's Manual FIXMOUNT(8)
fixmount -- fix remote mount entries
fixmount [-adervq] [-h name] host ...
fixmount is a variant of showmount(8) that can delete bogus mount entries
in remote mountd(8) daemons. The actions specified by the options are
performed for each host in turn.
-a -d -e
These options work as in showmount(8) except that only entries
pertaining to the local host are printed.
-r Removes those remote mount entries on host that do not correspond
to current mounts, i.e., which are left-over from a crash or are
the result of improper mount protocol. The actuality of mounts
is verified using the entries in /etc/mtab.
-v Verify remote mounts. Similar to -r except that only a notifica-
tion message is printed for each bogus entry found. The remote
mount table is not changed.
-A Issues a command to the remote mountd declaring that all of its
file systems have been unmounted. This should be used with cau-
tion, as it removes all remote mount entries pertaining to the
local system, whether or not any file systems are still mounted
-v Be quiet. Suppresses error messages due to timeouts and
``Program not Registered'', i.e., due to remote hosts not sup-
porting RPC or not running mountd.
Pretend the local hostname is name. This is useful after the
local hostname has been changed and rmtab entries using the old
name remain on a remote machine. Unfortunately, most mountd's
won't be able to successfully handle removal of such entries, so
this option is useful in combination with -v only.
This option also saves time as comparisons of remotely recorded
and local hostnames by address are avoided.
List of current mounts.
Backup file for remote mount entries on NFS server.
mtab(5), rmtab(5), mountd(8), showmount(8)
No attempt is made to verify the information in /etc/mtab itself.
Since swap file mounts are not recorded in /etc/mtab, a heuristic spe-
cific to SunOS is used to determine whether such a mount is actual
(replacing the string 'swap' with 'root' and verifying the resulting
Symbolic links on the server will cause the path in the remote entry to
differ from the one in /etc/mtab. To catch those cases, a file system is
also deemed mounted if its local mount point is identical to the remote
entry. I.e., on a SunOS diskless client,
server:/export/share/sunos.4.1.1 is actually /usr/share. Since the local
mount point is /usr/share as well this will be handled correctly.
There is no way to clear a stale entry in a remote mountd after the local
hostname (or whatever reverse name resolution returns for it) has been
changed. To take care of these cases, the remote /etc/rmtab file has to
be edited and mountd restarted.
The RPC timeouts for mountd calls can only be changed by recompiling. The
defaults are 2 seconds for client handle creation and 5 seconds for RPC
Jan-Simon Pendry <jspATdoc.uk>, Department of Computing, Imperial
College, London, UK.
Erez Zadok <ezkATcs.edu>, Department of Computer Science, Colum-
bia University, New York, USA.
Other authors and contributors to am-utils are listed in the AUTHORS file
distributed with am-utils.
The fixmount utility appeared in FreeBSD 3.0.
BSD February 26, 1993 BSD