FINGERD(8) BSD System Manager's Manual FINGERD(8)
fingerd -- remote user information server
fingerd [-s] [-l] [-p filename]
The fingerd utility uses a simple protocol based on RFC1196 that provides
an interface to finger(1) at several network sites. It is supposed to
return a friendly, human-oriented status report on either the system at
the moment or a particular person in depth. There is no required format
and the protocol consists mostly of specifying a single ``command line'',
thus, fingerd can also be used to implement other protocols in conjunc-
tion with the -p flag.
The fingerd utility is started by inetd(8), which listens for TCP
requests at port 79. Once connected it reads a single command line ter-
minated by a <CRLF> which is passed to finger(1). The fingerd utility
closes its connections as soon as the output is finished.
If the line is null (i.e., just a <CRLF> is sent) then finger(1) returns
a ``default'' report that lists all people logged into the system at that
If a user name is specified (e.g. eric<CRLF>) then the response lists
more extended information for only that particular user, whether logged
in or not. Allowable ``names'' in the command line include both ``login
names'' and ``user names''. If a name is ambiguous, all possible deriva-
tions are returned.
The following options may be passed to fingerd as server program argu-
ments in /etc/inetd.conf:
-s Enable secure mode. Queries without a user name are rejected and
forwarding of queries to other remote hosts is denied.
-l Enable logging. The name of the host originating the query is
reported via syslog(3) at LOG_NOTICE priority.
-p Use an alternate program as the local information provider. The
default local program executed by fingerd is finger(1). By spec-
ifying a customized local server, this option allows a system
manager to have more control over what information is provided to
remote sites. If -p is specified, fingerd will also set the
environment variable FINGERD_REMOTE_HOST to the name of the host
making the request.
Connecting directly to the server from a TIP or an equally narrow-minded
TELNET-protocol user program can result in meaningless attempts at option
negotiation being sent to the server, which will foul up the command line
interpretation. The fingerd utility should be taught to filter out IAC's
and perhaps even respond negatively (IAC WON'T) to all option commands
The fingerd utility appeared in 4.3BSD.
BSD June 4, 1993 BSD