EXTATTRCTL(8) OpenBSD System Manager's Manual EXTATTRCTL(8)
extattrctl - manage FFS extended attributes
extattrctl start path
extattrctl stop path
extattrctl initattr [-f] [-p path] attrsize attrfile
extattrctl enable path attrnamespace attrname attrfile
extattrctl disable path attrnamespace attrname
extattrctl is the management utility for extended attributes over the FFS
file system. extattrctl allows the starting and stopping of extended at-
tributes on a file system, as well as initialization of attribute backing
files, and enabling and disabling of specific extended attributes on a
The first argument on the command line indicates the operation to be per-
formed. Operation must be one of the following:
Start extended attribute support on the file system named using
path. The file system must be an FFS file system, and the
UFS_EXTATTR kernel option must have been enabled.
Stop extended attribute support on the file system named using
path. Extended attribute support must previously have been
initattr [-f] [-p path] attrsize attrfile
Create and initialize a file to use as an attribute backing file.
You must specify a maximum per-inode size for the attribute in
bytes in attrsize, as well as the file where the attribute will
be stored, using attrfile.
The -f argument may be used to indicate that it is alright to
overwrite an existing attribute backing file; otherwise, if the
target file exists, an error will be returned.
The -p path argument may be used to preallocate space for all at-
tributes rather than relying on sparse files to conserve space.
This has the advantage of guaranteeing that space will be avail-
able for attributes when they are written, preventing low disk
space conditions from denying attribute service.
This file should not exist before running initattr.
enable path attrnamespace attrname attrfile
Enable an attribute named attrname in the namespace attrnamespace
on the file system identified using path, and backed by initial-
ized attribute file attrfile. Available namespaces are "user"
and "system". The backing file must have been initialized using
initattr before its first use. Attributes must have been started
on the file system prior to the enabling of any attributes.
disable path attrnamespace attrname
Disable the attributed named attrname in namespace attrnamespace
on the file system identified by path. Available namespaces are
"user" and "system". The file system must have attributes start-
ed on it, and the attribute must have been enabled using enable.
# extattrctl start /
Start extended attributes on the root file system.
# extattrctl initattr 17 /.attribute/md5
Create an attribute backing file in /.attribute/md5, and set the maximum
size of each attribute to 17 bytes, with a sparse file used for storing
# extattrctl enable / system md5 /.attribute/md5
Enable an attribute named md5 on the root file system, backed from the
# extattrctl disable / md5
Disable the attribute named md5 on the root file system.
# extattrctl stop /
Stop extended attributes on the root file system.
getextattr(8), setextattr(8), extattr(9)
Extended attribute support was developed as part of the TrustedBSD Pro-
ject. It was developed to support security extensions requiring addi-
tional labels to be associated with each file or directory.
Robert N M Watson
OpenBSD 3.6 March 30, 2000 2