EEPROM(8) BSD System Manager's Manual EEPROM(8)
eeprom -- display or modify contents of the EEPROM or openprom
SUN 3 SYNOPSIS
eeprom [-] [-c] [-f device] [-i] [field[=value] ...]
SPARC and SPARC64 SYNOPSIS
eeprom [-] [-c] [-f device] [-i] [-v] [field[=value] ...]
eeprom provides an interface for displaying and changing the contents of
the EEPROM or openprom. Without any arguments, eeprom will list all of
the known fields and their corresponding values. When given the name of
a specific field, eeprom will display that value or set it if the field
name is followed by '=' and a value. Only the super-user may modify the
contents of the EEPROM or openprom.
The options are as follows:
- Commands are taken from stdin and displayed on stdout.
-c eeprom will fix incorrect checksum values and exit. This flag is
quietly ignored on systems with an openprom.
On systems with an EEPROM, use device instead of the default
/dev/eeprom. On systems with an openprom, use device instead of
the default /dev/openprom.
-i If checksum values are incorrect, eeprom will ignore them and
continue after displaying a warning. This flag is quietly
ignored on systems with an openprom.
The following options are valid only on the SPARC and will produce an
error when used on a Sun 3:
-v On systems with an openprom, be verbose when setting a value.
Systems with an EEPROM are always verbose.
The -v option is also present on sparc64 systems.
FIELDS AND VALUES
The following fields and values are for systems with an EEPROM:
hwupdate A valid date, such as ``7/12/95''. The strings
``today'' and ``now'' are also acceptable.
memsize How much memory, in megabytes, is installed in the
memtest How much memory, in megabytes, is to be tested upon
scrsize The size of the screen. Acceptable values are
``1024x1024'', ``1152x900'', ``1600x1280'', and
watchdog_reboot If true, the system will reboot upon reset. Other-
wise, the system will fall into the monitor.
default_boot If true, the system will use the boot device stored in
bootdev Specifies the default boot device in the form
cc(x,x,x), where 'cc' is a combination of two letters
such as 'sd' or 'le' and each 'x' is a hexadecimal
number between 0 and ff, less the prepending '0x'.
kbdtype This value is ``0'' for all Sun keyboards.
console Specifies the console type. Valid values are ``b&w'',
``ttya'', ``ttyb'', ``color'', and ``p4opt''.
keyclick If true, the keys click annoyingly.
diagdev This is a string very similar to that used by bootdev.
It specifies the default boot device when the diagnos-
tic switch is turned on.
diagpath A 40-character, NULL-terminated string specifying the
kernel or standalone program to load when the diagnos-
tic switch is turned on.
columns An 8-bit integer specifying the number of columns on
rows An 8-bit integer specifying the number of rows on the
ttya_use_baud Use the baud rate stored in ttya_baud instead of the
ttya_baud A 16-bit integer specifying the baud rate to use on
ttya_no_rtsdtr If true, disables RTS/DTR.
ttyb_use_baud Similar to ttya_use_baud, but for ttyb.
ttyb_baud Similar to ttya_baud, but for ttyb.
ttyb_no_rtsdtr Similar to ttya_no_rtsdtr, but for ttyb.
banner An 80-character, NULL-terminated string to use at
power-up instead of the default Sun banner.
Note that the secure, bad_login, and password fields are not currently
Since the openprom is designed such that the field names are arbitrary,
explaining them here is dubious. Below are field names and values that
one is likely to see on a system with an openprom. NOTE: this list may
be incomplete or incorrect due to differences between revisions of the
sunmon-compat? If true, the old EEPROM-style interface will be
used while in the monitor, rather than the open-
selftest-#megs A 32-bit integer specifying the number of
megabytes of memory to test upon power-up.
oem-logo A 64bitx64bit bitmap in Sun Iconedit format. To
set the bitmap, give the pathname of the file
containing the image. NOTE: this property is not
oem-logo? If true, enables the use of the bitmap stored in
oem-logo rather than the default Sun logo.
oem-banner A string to use at power up, rather than the
default Sun banner.
oem-banner? If true, enables the use of the banner stored in
oem-banner rather than the default Sun banner.
ttya-mode A string of five comma separated fields in the
format ``9600,8,n,1,-''. The first field is the
baud rate. The second field is the number of
data bits. The third field is the parity;
acceptable values for parity are 'n' (none), 'e'
(even), 'o' (odd), 'm' (mark), and 's' (space).
The fourth field is the number of stop bits. The
fifth field is the 'handshake' field; acceptable
values are '-' (none), 'h' (RTS/CTS), and 's'
ttya-rts-dtr-off If true, the system will ignore RTS/DTR.
ttya-ignore-cd If true, the system will ignore carrier detect.
ttyb-mode Similar to ttya-mode, but for ttyb.
ttyb-rts-dtr-off Similar to ttya-rts-dtr-off, but for ttyb.
ttyb-ignore-cd Similar to ttya-ignore-cd, but for ttyb.
sbus-probe-list Four digits in the format ``0123'' specifying
which order to probe the sbus at power-up. It is
unlikely that this value should ever be changed.
screen-#columns An 8-bit integer specifying the number of columns
on the console.
screen-#rows An 8-bit integer specifying the number of rows on
auto-boot? If true, the system will boot automatically at
watchdog-reboot? If true, the system will reboot upon reset. Oth-
erwise, system will fall into the monitor.
input-device One of the strings ``keyboard'', ``ttya'', or
``ttyb'' specifying the default console input
output-device One of the strings ``screen'', ``ttya'', or
``ttyb'' specifying the default console output
keyboard-click? If true, the keys click annoyingly.
sd-targets A string in the format ``31204567'' describing
the translation of physical to logical target.
st-targets Similar to sd-targets, but for tapes. The
default translation is ``45670123''.
scsi-initiator-id The SCSI ID of the on-board SCSI controller.
hardware-revision A 7-character string describing a date, such as
last-hardware-update Similar to hardware-revision, describing when the
CPU was last updated.
diag-switch? If true, the system will boot and run in diagnos-
/dev/eeprom The EEPROM device on systems with an EEPROM.
/dev/openprom The openprom device on systems with an openprom.
The fields and their values are not necessarily well defined on systems
with an openprom. Your mileage may vary.
There are a few fields known to exist in some revisions of the EEPROM
and/or openprom that are not yet supported. Most notable are those
relating to password protection of the EEPROM or openprom.
Avoid gratuitously changing the contents of the EEPROM. It has a limited
number of write cycles.
The date parser isn't very intelligent.
BSD November 19, 2000 BSD