EDITMAP(8) OpenBSD System Manager's Manual EDITMAP(8)
editmap - query and edit records in database maps for sendmail
editmap [-C file] [-N] [-f] [-q | -u | -x] maptype mapname key
editmap queries or edits one record in database maps used by the keyed
map lookups in sendmail(8). Arguments are passed on the command line and
output (for queries) is directed to standard output.
Depending on how it is compiled, editmap handles up to three different
database formats, selected using the maptype parameter. They may be
dbm DBM format maps. This requires the ndbm(3) library.
btree B-Tree format maps. This requires the new Berkeley DB li-
hash Hash format maps. This also requires the Berkeley DB li-
If the TrustedUser option is set in the sendmail configuration file and
editmap is invoked as root, the generated files will be owned by the
-C file Use the specified sendmail(8) configuration file for looking
up the TrustedUser option.
-N Include the null byte that terminates strings in the map (for
-f Normally all upper case letters in the key are folded to low-
er case. This flag disables that behaviour. This is intend-
ed to mesh with the -f flag in the ``K'' line in sendmail.cf.
The value is never case folded.
-q Query the map for the specified key. If found, print value
to standard output and exit with 0. If not found then print
an error message to stdout and exit with EX_UNAVAILABLE.
-u Updates the record for key with value or inserts a new record
if one doesn't exist. Exits with 0 on success or EX_IOERR on
-x Deletes the specific key from the map. Exits with 0 on suc-
cess or EX_IOERR on failure.
The editmap command appeared in OpenBSD 3.0.
OpenBSD 3.6 March 15, 2003 1