DISKLABEL(8) BSD System Manager's Manual DISKLABEL(8)
disklabel - read and write disk pack label
disklabel [-r] disk
disklabel -w [-r] disk disktype [packid]
disklabel -e [-r] disk
disklabel -R [-r] disk protofile
disklabel [-NW] disk
disklabel -B [-b boot1 [-s boot2]] disk [disktype]
disklabel -w -B [-b boot1 [-s boot2]] disk disktype [packid]
disklabel -R -B [-b boot1 [-s boot2]] disk protofile [disktype]
Disklabel can be used to install, examine or modify the label on a disk
drive or pack. When writing the label, it can be used to change the
drive identification, the disk partitions on the drive, or to replace a
damaged label. On some systems, disklabel can be used to install boot-
strap code as well. There are several forms of the command that read
(display), install or edit the label on a disk. Each form has an addi-
tional option, -r, which causes the label to be read from or written to
the disk directly, rather than going through the system's in-core copy of
the label. This option may allow a label to be installed on a disk with-
out kernel support for a label, such as when labels are first installed
on a system; it must be used when first installing a label on a disk.
The specific effect of -r is described under each command. The read and
install forms also support the -B option to install bootstrap code.
These variants are described later.
The first form of the command (read) is used to examine the label on the
named disk drive (e.g. sd0 or /dev/rsd0c). It will display all of the
parameters associated with the drive and its partition layout. Unless
the -r flag is given, the kernel's in-core copy of the label is dis-
played; if the disk has no label, or the partition types on the disk are
incorrect, the kernel may have constructed or modified the label. If the
-r flag is given, the label from the raw disk will be displayed rather
than the in-core label.
The second form of the command, with the -w flag, is used to write a
standard label on the designated drive. The required arguments to
disklabel are the drive to be labelled (e.g. sd0), and the drive type as
described in the disktab(5) file. The drive parameters and partitions
are taken from that file. If different disks of the same physical type
are to have different partitions, it will be necessary to have separate
disktab entries describing each, or to edit the label after installation
as described below. The optional argument is a pack identification
string, up to 16 characters long. The pack id must be quoted if it con-
tains blanks. If the -r flag is given, the disk sectors containing the
label and bootstrap will be written directly. A side-effect of this is
that any existing bootstrap code will be overwritten and the disk ren-
dered unbootable. If -r is not specified, the existing label will be up-
dated via the in-core copy and any bootstrap code will be unaffected. If
the disk does not already have a label, the -r flag must be used. In ei-
ther case, the kernel's in-core label is replaced.
An existing disk label may be edited by using the -e flag. The label is
read from the in-core kernel copy, or directly from the disk if the -r
flag is also given. The label is formatted and then supplied to an edi-
tor for changes. If no editor is specified in an EDITOR environment
variable, vi(1) is used. When the editor terminates, the formatted label
is reread and used to rewrite the disk label. Existing bootstrap code is
unchanged regardless of whether -r was specified.
With the -R flag, disklabel is capable of restoring a disk label that was
formatted in a prior operation and saved in an ascii file. The prototype
file used to create the label should be in the same format as that pro-
duced when reading or editing a label. Comments are delimited by # and
newline. As with -w, any existing bootstrap code will be clobbered if -r
is specified and will be unaffected otherwise.
The -NW flags for disklabel explicitly disallow and allow, respectively,
writing of the pack label area on the selected disk.
The final three forms of disklabel are used to install boostrap code on
machines where the bootstrap is part of the label. The bootstrap code is
comprised of one or two boot programs depending on the machine. The -B
option is used to denote that bootstrap code is to be installed. The -r
flag is implied by -B and never needs to be specified. The name of the
boot program(s) to be installed can be selected in a variety of ways.
First, the names can be specified explicitly via the -b and -s flags. On
machines with only a single level of boot program, -b is the name of that
program. For machines with a two-level bootstrap, -b indicates the pri-
mary boot program and -s the secondary boot program. If the names are
not explicitly given, standard boot programs will be used. The boot pro-
grams are located in /usr/mdec. The names of the programs are taken from
the ``b0'' and ``b1'' parameters of the disktab(5) entry for the disk if
disktype was given and its disktab entry exists and includes those param-
eters. Otherwise, boot program names are derived from the name of the
disk. These names are of the form basenameboot for the primary (or only)
bootstrap, and bootbasename for the secondary bootstrap; for example,
/usr/mdec/sdboot and /usr/mdec/bootsd if the disk device is sd0.
The first of the three boot-installation forms is used to install boot-
strap code without changing the existing label. It is essentially a read
command with respect to the disk label itself and all options are related
to the specification of the boot program as described previously. The
final two forms are analogous to the basic write and restore versions ex-
cept that they will install bootstrap code in addition to a new label.
Display the in-core label for sd0 as obtained via /dev/rsd0c.
disklabel -w -r /dev/rsd0c sd2212 foo
Create a label for sd0 based on information for ``sd2212'' found in
/etc/disktab. Any existing bootstrap code will be clobbered.
disklabel -e -r sd0
Read the on-disk label for sd0, edit it and reinstall in-core as well as
on-disk. Existing bootstrap code is unaffected.
disklabel -R sd0 mylabel
Restore the on-disk and in-core label for sd0 from information in
mylabel. Existing bootstrap code is unaffected.
disklabel -B sd0
Install a new bootstrap on sd0. The boot code comes from
/usr/mdec/sdboot and possibly /usr/mdec/bootsd. On-disk and in-core la-
bels are unchanged.
disklabel -w -B /dev/rsd0c -b newboot sd2212
Install a new label and bootstrap. The label is derived from disktab in-
formation for ``sd2212'' and installed both in-core and on-disk. The
bootstrap code comes from the file /usr/mdec/newboot.
The kernel device drivers will not allow the size of a disk partition to
be decreased or the offset of a partition to be changed while it is open.
Some device drivers create a label containing only a single large parti-
tion if a disk is unlabeled; thus, the label must be written to the ``a''
partition of the disk while it is open. This sometimes requires the de-
sired label to be set in two steps, the first one creating at least one
other partition, and the second setting the label on the new partition
while shrinking the ``a'' partition.
On some machines the bootstrap code may not fit entirely in the area al-
located for it by some filesystems. As a result, it may not be possible
to have filesystems on some partitions of a ``bootable'' disk. When in-
stalling bootstrap code, disklabel checks for these cases. If the in-
stalled boot code would overlap a partition of type FS_UNUSED it is
marked as type FS_BOOT. The newfs(8) utility will disallow creation of
filesystems on FS_BOOT partitions. Conversely, if a partition has a type
other than FS_UNUSED or FS_BOOT, disklabel will not install bootstrap
code that overlaps it.
When a disk name is given without a full pathname, the constructed device
name uses the ``a'' partition on the tahoe, the ``c'' partition on all
4.2 Berkeley Distribution April 19, 1994 3