DISKINFO(8) BSD System Manager's Manual DISKINFO(8)
diskinfo -- get information about disk device
diskinfo [-tv] disk ...
The diskinfo utility prints out information about a disk device, and
optionally runs a naive performance test on the device.
If given no arguments, the output will be a single line per specified
device with the following fields: device name, sectorsize, media size in
bytes, media size in sectors, firmware cylinders, firmware heads, and
firmware sectors. The last three fields are only present if the informa-
tion is available.
If given the -v option, the fields will be printed one per line with a
The -t option triggers a simple and rather naive benchmark of the disks
seek and transfer performance.
There are in order of increasing severity: lies, damn lies, statistics,
and computer benchmarks.
The diskinfo command appeared in FreeBSD 5.1.
BSD April 9, 2003 BSD