CONFIG(8) BSD System Manager's Manual CONFIG(8)
config - build system configuration files
config [-p] system_name
This is the old version of the config program. It understands the old
autoconfiguration scheme used on the HP300, DECstation, and derivative
platforms. The new version of config is used with the SPARC and i386
platforms. Only the version of config applicable to the architecture
that you are running will be installed on your machine.
Config builds a set of system configuration files from the file
SYSTEM_NAME which describes the system to configure. A second file tells
config what files are needed to generate a system and can be augmented by
configuration specific set of files that give alternate files for a spe-
cific machine. (see the FILES section below)
Available option and operand:
-p If the -p option is supplied, config will configure a system
for profiling; for example, kgmon(8) and gprof(1).
SYSTEM_NAME specifies the name of the system configuration file contain-
ing device specifications, configuration options and other
system parameters for one system configuration.
Config should be run from the conf subdirectory of the system source
(usually /sys/conf). Config assumes the directory ../SYSTEM_NAME exists
and places all output files there. The output of config consists of a
number of files; for the VAX, they are: ioconf.c, a description of what
I/O devices are attached to the system; ubglue.s, a set of interrupt ser-
vice routines for devices attached to the UNIBUS; ubvec.s, offsets into a
structure used for counting per-device interrupts; Makefile, used by
make(1) in building the system; header files, definitions of the number
of various devices that will be compiled into the system; swap configura-
tion files, definitions for the disk areas to be used for swapping, the
root file system, argument processing, and system dumps.
After running config, it is necessary to run ``make depend'' in the di-
rectory where the new makefile was created. Config prints a reminder of
this when it completes.
If any other error messages are produced by config, the problems in the
configuration file should be corrected and config should be run again.
Attempts to compile a system that had configuration errors are likely to
/sys/conf/Makefile.vax generic makefile for the VAX
/sys/conf/files list of common files system is built from
/sys/conf/files.vax list of VAX specific files
/sys/conf/devices.vax name to major device mapping file for the VAX
/sys/conf/files.ERNIE list of files specific to ERNIE system
The SYNOPSIS portion of each device in section 4.
Building 4.3 BSD UNIX System with Config.
The line numbers reported in error messages are usually off by one.
The config command appeared in 4.1BSD.
4th Berkeley Distribution April 19, 1994 2