CLRI(8) OpenBSD System Manager's Manual CLRI(8)
clri - clear inodes
clri special_device inode_number [...]
clri is obsoleted for normal file system repair work by fsck(8).
clri zeros out the inodes with the specified inode numbers on the
filesystem residing on the given special_device. The fsck(8) utility is
usually run after clri to reclaim the zero'ed inodes and the blocks pre-
viously claimed by those inodes. Both read and write permission are re-
quired on the specified special_device.
The primary purpose of this routine is to remove a file which for some
reason is not being properly handled by fsck(8). Once removed, it is an-
ticipated that fsck(8) will be able to clean up the resulting mess.
inode(5), fsck(8), fsdb(8), ncheck(8)
If the file is open, the work of clri will be lost when the inode is
written back to disk from the inode cache.
OpenBSD 3.6 April 19, 1994 1