CHROOT(8) OpenBSD System Manager's Manual CHROOT(8)
chroot - change root directory
chroot [-g group,group,...] [-u user] newroot [command]
The chroot command changes its root directory to the supplied directory
newroot and executes command, if supplied, or an interactive copy of the
The chroot command is restricted to the superuser.
The options are as follows:
Override the primary and supplemental group IDs. The primary
group ID is set to the first group in the list. Any remaining
groups are placed in the supplemental group ID vector. Each
group listed must exist in the group(5) databases.
Set user ID to user (which must exist in the passwd(5) database).
The primary and supplemental group IDs will be set based on the
user's entries in the passwd(5) and group(5) databases unless
overridden by the -g option.
SHELL If set, the string specified by SHELL is interpreted as the name
of the shell to execute. If the variable SHELL is not set,
/bin/sh is used.
chdir(2), chroot(2), setgid(2), setgroups(2), setuid(2), group(5),
The chroot utility first appeared in 4.4BSD.
chroot should never be installed setuid root, as it would then be possi-
ble to exploit the program to gain root privileges.
OpenBSD 3.6 February 7, 2003 1