CHKGRP(8) BSD System Manager's Manual CHKGRP(8)
chkgrp -- check the syntax of the group file
The chkgrp utility scans the given file or, failing that, the system-wide
group file for errors. Specifically, it checks that every non-blank,
non-comment entry is composed of four colon-separated fields, that none
of them contains whitespace, and that the third field (the group ID) is
/etc/group group database file
For each error found, chkgrp will print an error message containing the
name of the file being scanned and the line number on which the error was
found. Otherwise no output is produced.
The chkgrp utility returns EX_DATAERR if errors were found in the group
file, and EX_OK otherwise.
The chkgrp utility appeared in FreeBSD 3.0.
The chkgrp utility and this manual page were written by Dag-Erling
Should check fields more thoroughly for allowed/disallowed characters,
and the range of the group ID.
BSD May 5, 1998 BSD