BOOT(8) BSD System Manager's Manual (Tahoe Architecture) BOOT(8)
boot - system bootstrapping procedures
Power fail and crash recovery. Normally, the system will reboot itself at
power-up or after crashes. An automatic consistency check of the file
systems will be performed, and unless this fails, the system will resume
Cold starts. These are processor-type dependent. On the CCI Power 6/32
and related processors, the system will do a standard autoboot from drive
0 upon power-up or reset. This automatic boot may be cancelled by typing
a `#' in the first few seconds after reset. This enters console mode;
the console prompt is `>' or `#'. The boot flags can be set to any hex-
adecimal value -n with the command
#> p23 n.
The default device may be examined or set; see the Diagnostics and Debug-
ging manual for the processor for details on device naming and syntax.
After setting the boot flags and/or device, a bootstrap sequence can be
A specific device or bootstrap file may be used; for example,
#> fb xfd(1,0)
would boot from the `a' partition on XFD drive 1.
The file specifications used for the boostrap when loaded with the
``askme'' flag (register 23 set to 1 or 3) are of the form:
where device is the type of the device to be searched, adaptor is number
of the VERSAbus (or VMEbus) to which the device is attached, controller
is the unit number of the controller on that buss, unit is the unit num-
ber of the disk or tape, and minor is the disk partition or tape file
number. Leading adaptor or controller numbers default to 0. Normal line
editing characters can be used when typing the file specification. The
following list of supported devices may vary from installation to instal-
dk SMD or ESDI disks on VDDC or SMD-E
cy tape on Ciprico Tapemaster controller
For example, to boot from a file system which starts at cylinder 0 of
unit 0 of an SMD-E disk, type `dk(0,0)vmunix' to the boot prompt;
`dk(2,1,0)vmunix' would specify drive 1 on SMD-E controller 2.
In an emergency, the bootstrap methods described in the paper Installing
and Operating 4.3 BSD-tahoe UNIX on the Tahoe can be used to boot from a
/vmunix system code
/boot system bootstrap
halt(8), reboot(8), shutdown(8)
The disklabel format used by some versions of the console processor is
different than the format used by UNIX and the bootstrap.
4.4BSD April 19, 1994 2